Russound MCA-C5 Losing Connections - Seemingly Random


Active Member
I'm hoping that someone can point me in a direction.
I have a Russound MCA-C5 that will lose ALL of it's communication to the outside world at random intervals.  I have had it work flawlessly for 2 weeks and also had it lose it's connection in a hour.  The only way to get it back, is to power cycle the unit and then restart Home Assistant.
When it goes away, nothing works.  The built-in USB evens fails to communicate.  No ping to it's IP.  Nothing.
I have it connected directly to the router eliminating any switches.  I've changed the router.  Using a short shielded CAT6 patch cable.  I have tried it with a standard CAT5e as well.
Has anyone seen anything like this?  It seems like it's hardware.  But the fact that it can run for 2 weeks leads me to think it's something else.
So before I decide to dump this thing, I figured I'd throw it out here to see if anyone knows something.
Does it have a reserved address in your router? Is there a chance that it is having trouble renewing its IP address in in DHCP when the lease is up?
Absolutely.  Reserved on the router.  Also tried using static on the Russound itself.  Same symptoms either way.  It's a weird one.
Well, yes and no.  I have it working fairly flawlessly in Home-Assistant.  But I had to use RS232.  I could not get IP to work at all.
I did speak to one of my customers that is a Russound dealer/installer and he said that the things were notoriously troublesome unless you used serious network switches and router.  He uses Luxul and has not had issues.  My guess is that any high quality managed switch would probably be better.  But honestly, as long as I can control volume and  sources, I don't carry if it's IP or serial.  Fortunately, the HA driver seems to be able to deal with it fine.
Just to make sure that the network contacts are OK.
1 - disconnect the power from the Russound and unplug any cables to it.
2 - look to see if the copper wires are shiny inside of the RJ-45 port with a flashlight.
3 - wet a QTip with vinegar and wipe the copper contacts inside of the RJ-45 port.  
4 - wet a second QTip with bicarbonate dissolved in some water wipe the copper contacts inside of the RJ-45 port
5 - we a third QTip with alcohol and wipe the copper contacts inside of the RJ-45 port.
6 - use a blow dryer for a few seconds on the RJ-45 port if you want.
Use a cat5e patch cable instead of a cat6 cable.  It should connect to any switch or router just fine. 
In windows at a command prompt ping the IP of the Russound and watch it for a bit to see if any pings fail.
Pete - I know I tried all of that and more.  There were times when I had it working for weeks and then it would fail.  Then after weeks, it failed every day or two.  I finally got fed up with it and was about to get rid of it, when I decided to try RS232.  Haven't had a failure in over a year.  I think that Russound just did a bad implementation of their Ethernet stuff.  Or my unit is bad.  But I have seen a LOT of people with issues on those. been using RS-232 with my two CAAS66's for many many years with no issues.
Yeah here one of my power LEDs went out years ago.  I called Russound for repair and it wasn't worth the money to repair the CAA66.
Just relating to my home network here over the years have gone "a la carte" removing the ISP provided combo SOHO router.  Current configuration is:
1 - cable ISP connection
2 - Arris SB6190 modem 
3 - PFSense firewall (6 Intel Gb ports)
4 - managed layer 2 switches
5 - Ruckus WAPs