ELK M1 Stuck in Armed 'Stay' Modes


Hello All:
This is my first post and first install so please bear with me, I may over-explain this or not have the correct information...
I recently installed and programmed an ELK M1 pannel in my home. Everything seemed to go smoothly through the install and programming process but I am having trouble ever since the first time I armed the system. 
I programmed the system which has 13 zones using a touchscreen nav keypad. At the time this was the only keypad I had hooked up, I intended to add a second keypad after getting everything operational. After programming, I had one zone that was violated (bad sensor) that I knew I would need to replace. For the time being, I decided to try and bypass this zone to arm for the night. This zone was configured to enable bypass. The first problem I noticed was that I could not seem to get the system to bypass this zone. After pressing bypass on the nav keypad, entering the zone number, and pressing bypass again, it still would not bypass the zone.
In order to continue on I decided to go back into the programming and disable this zone until I could replace the sensor. I did so and the system showed 'Ready'. I then set the system into 'stay' mode. The voice announcement came across that 'area 1 was armed, stay'. To complete my test I put in the new master code to try and disarm the system. This is when I discovered that the system would not disarm. I tried the master code I knew I had programmed, I tried the default code,  I even tried the installer code - none of which will disarm the system. As a point of interest, when I am keying in the code on the nav keypad, I see one * appear for the first digit I press, then before I can press the second digit of the code, the * disappears. Not sure if this is how it is designed to function. I would have thought that my code would appear as all ****** as I am done keying in the code.
Regardless, I went to the panel and shut the whole system off via the switch on the board. It was then I noticed that I neglected to put a jumper on JP3. I did jumper the nav keypad but since there was only one keypad, I believe I needed another jumper on JP3. 
I put on the JP3 jumper and powered the system back up. It is still in stay mode and none of the codes work. Same as before.
To see if my problem was the Nav keypad, I hooked up my second keypad, an M1KP2. I made sure to remove the JP3 jumper and made sure the jumper was set on the M1KP2. I still experience the same trouble. None of my codes seem to disarm the system. As a point of interest, if I press 'exit' on the keypad, it re-starts the exit timer (as expected since I enabled this in my programming) what I didn't expect is that between the M1KP2 and the Nav keypad, the countdown is different!
At this point, I am not sure where I am at with the system. If I didn't have the jumpers properly set, is it possible all of my programming from the nav never made it to the control? This doesn't seem right as I was able to disable the zone with the faulty sensor to arm it. Is this why my new master code isn't working? If so, wouldn't the default code work? 
My plan now, is to keep the jumper JP3 and hookup my other hardkey keypad and see what I have there but I am open to other suggestions as to what is going on.
Has anyone else experienced something like this?


Senior Member
This sounds like a RS-485 data bus problem.
If you are seeing the * disappear, then the processor on the keypad could be resetting.  Check to make sure you have over 12.5 volts at the 12V power connections on the keypad. 
Check to make sure Data A on the M1 connects to Data A on the keypad, also Data B to Data B.
With power turned off on the M1, measure the resistance across Data A and Data B on the RS485 serial port.  It should show about 65 ohms.  Less than 40 or more than 100 means that the end of line RS485 jumpers are not installed correctly.


Senior Member
I'm not sure of a solution, but the * should definitely be staying on the screen while entering the passcode.  So if you passcode is 4 digits, you should see **** when you are done.


Thanks for the help! I started by testing the voltage at the data bus on the panel and got 13v dc. When pulling the nav screen out of its mount to check voltage at the other end, I noticed the keypad was working when it was off the wall. Looking at the mount it looks like the mounting screws had round heads that stuck out pretty far. My guess at this point is that they were shorting the circuit board when it was mounted.

I know the manual says to use flat head screws but I had guessed the screws that came with the keypad would be good enough, guess not. All seems to be operating properly now that I have flat heads in there.

Thanks again all!