Pete's Blog Espurna upgrading to Tasmota help

Blog posts by pete_c


Here have two old Sonoff basics running Espurna 1.14.1 firmware version for 4 DS18B20 temperature sensors. Its been a couple of years now and they are running fine. I would like to switch these over to Tasmota firmware as I am using Tasmota Admin in Home Assistant.

The two devices running with temperature sensors are older Sonoff basic devices.


I would like to try to update via the Espurna Web gui instead of the JTAG methodology. Anyone try this?

Thinking of first updating to a minimal tasmota bin then upgrading it to a full version. I am certain that it will see the 4 temperature sensors.

Maybe first updating Espurna to newer dev version would work?
I haven't tried it myself, but I think it will work just fine. Worse case if it doesn't work is that you'll have to JTAG it, so why not try via the GUI first?
Tried to update old Sonoff R1 device with Tasmota minimal bin. It went to AP mode but couldn't get to the GUI. JTAG'd it to current version of Tasmota with Tasmotizer running in Linux. Worked and it sees the 4 DS18XX fine. This is the old Sonoff Basic R1 hardware device where I had to saw cut the AC power lines. I left it AC powered off as I updated the firmware.

I had some issues doing the second Espurna Sonoff Basic device. JTAG was the easy part. I used ESPTool command line to erase then write the Sonoff bin. Really was the same as using Tasmotizer. I think that Espurna wrote some stuff that I couldn't wipe out. Programming it in AP mode would lose the configuration of my WLAN SSIDs. So went to restoring the back up of the first Sonoff basic to Tasmota which is a nice option in AP mode.

Booted fine to the network. Then changed the name as it came up as a duplicate entry on HA.

Next here are Espurna updated Magic Home RGB controllers that I am using in single color mode for the Kitchen under counter illumination. These are modded a bit with a temperature combo sensor and digital on off pot.