Gmail not allowing emails to be sent via M1 XEP as of May 30 2022?

dean830

Member
Gmail no longer allowing less secure apps. 
 
My M1 XEP stopped sending emails via my gmail account on June 6th. After troubleshooting I found this. Back up and running after switching to GMX.
 
Less secure apps & your Google Account





To help keep your account secure, from May 30, 2022, ​​Google no longer supports the use of third-party apps or devices which ask you to sign in to your Google Account using only your username and password.
Important: This deadline does not apply to Google Workspace or Google Cloud Identity customers. The enforcement date for these customers will be announced on the Workspace blog at a later date.
For more information, continue to read.





 
 

upstatemike

Senior Member
I had to fix this for my Elk M1 and my Blue Iris Box. Just have to enable 2 factor authentication in GMail. Then you will have a setting to let apps login with a special app password. Just add an app and it will generate a new password. Replace the password in your Elk M1 with the generated one without making any other changes and you are all set. Be sure to do this while ElkRP is connected to your panel because the changes won't work until you sync them.
 
Is anyone having issues with Gmail sending timely Verizon text messages out? I setup the Gmail app password, but my M1-XEP text messages are taking hours/sometime days to get delivered, making them useless..
 
Thanks for the reply, but I had already setup the app password in gmail. It works fine, but my Elk-M1 messages to my Verizon phone via text are taking hours or days to be delivered….

I tried duplicating this effort using a new yahoo account but yahoo is looking an app name. I’ve tried various combinations of Elk, M1, and/or XEP but haven’t found any that worked. It keeps responding with…”Sorry, this feature is not available right now.”

Any thoughts?
 

electron

Administrator
Staff member
Are you using the vtext.com domain, or how are you sending to Verizon? Do you experience this problem when sending from that gmail account to that Verizon address via web?
 

BraveSirRobbin

Moderator
I recently tried sending my wife a text via email on Verizon (via the vtext.com address) and Gmail came back with a message not deliverable response. Over a day later, she received the text. Not sure what is going on as this used to work.
 
I had setup specific M1XEP e-mails to communicate to my phone for various security issues and power outages.. That has been fine for 12 years until this app password setup change occurred earlier this year. Now Verizon text messages either never get delivered or are delivered days later… If I try to send a vtext to my phone from gmail, the same thing happens…. It’s like Verizon and Gmail don’t communicate properly… Yahoo seems to deliver vtexts in a timely manner, but I can never setup an app password in Yahoo because it is looking for a specific app Name, which I haven’t figured out.
The only work around I see is to change my M1XEP vtext emails to be delivered to an gmail email account..
 

electron

Administrator
Staff member
Unfortunately, I don't think this will ever get better.


If you have a smartphone, I would just get the PushOver.net app. It's cheap, and so powerful, I've been using it for years for all my automation platforms. The nice part is, there's an option to convert inbound emails to pushes, so you can still use email to accomplish the job, and since it's a push notification, it will probably be instant if there are no problems on the email side.
 
  • Like
Reactions: RAL
Thanks, I may end up doing just that.…

Has anyone been able to successfully setup an app password through yahoo for their Elk M1 systems?
 

electron

Administrator
Staff member
Thanks, I may end up doing just that.…

Has anyone been able to successfully setup an app password through yahoo for their Elk M1 systems?
It looks like Yahoo's app password feature may currently be broken:

Hi. We're very sorry app passwords are currently unavailable for Yahoo Mail accounts. Rest assured, you can still access your mail from the Yahoo Mail app or via a web browser. We apologize for any inconvenience this may cause you. Additionally, the option to auto-forward your emails is included in the Yahoo Mail Plus subscription, more details here: https://www.yahoo.com/plus/mail
Source
 
Top