New Router OmniPro Issues

abbachia

Member
Hoping someone here can point me in the right direction...feel like I'm missing something basic...
 
Been using a ASUS rtac66u for a long while...don't remember having much of a challenge getting it set up with the OPII panel (PCAccess remote access  etc)..
 
Decided to upgrade to Asus Zenwifi AX to get better coverage around my house with multiple nodes etc...was hopeful it'll be easy...all the Asus routers share a similar web console that i am already familiar with..
 
I cannot for the life of me get the router to "See" my panel..
 
The router comes out of box with a IP address of 192.168.50.1..rendering my panels static IP of 192.168.1.48 useless..
 
I changed the IP address via the keypad to 192.168.50.48...no luck
 
I thought maybe the changed IP wasn't taking do I changed the router to use 192.168.1.1 to allow the original panel IP address to function..  still nothing..
 
two red led lights to the left of the ethernet  port on the panel....the left one is on steady and the right one blinks intermittently..
 
so here is the question..is this a router setup problem or a OPII setup issue and does anyone have any pearls of wisdom that can shed some light on this issue?
 
Much thanks in advance
 

pete_c

Guru
It's easiest to change the IP, subnet, DHCP scope and any firewall rules you had in place on your new router.
 
This way everything that was running on your old network with the old router continues to work.  
 
The Long math way is to change all of the devices including the Omni panel to IPs on your new router...
 
First change the IP of your OmniPro panel to what it was via the keypad console.
 
Guessing you still have your old router.   Bring it up again and write down 
 
1 - IP of router
2 - subnet of router
3 - DHCP scope of router
4 - all firewall rules in place
 
Make sure your Omni panel is working.
 
Bring up your new router and match it all to the above.
 

pete_c

Guru
Personally here and for many years have purchased everything a la carte including the ISP modem with no dependencies other than the cable from the ISP.
 
Currently using:
 
1 - Arris SB6190 modem (upgrading to a newer Gb modem soon)
Amazon - ARRIS SURFboard SB6190 DOCSIS 3.0 Cable Modem, Approved for Cox, Spectrum, Xfinity & others (Black) - $91.52

2 - PFSense firewall - very much plug n play
Amazon - Protectli Vault 2 Port, Firewall Micro Appliance/Mini PC - Intel Dual Core, Barebone - $169.00

3 - Ruckus Wireless AP (POE connected). - This box sits on a wall inside of the main floor coat closet - you do not see it.

Amazon - Ruckus Zoneflex R610 Wave 2 Access Point (Smart Wi-Fi 3x3, 802.11ac, BeamFlex, Adaptive Antenna, POE) 901-R610-US00 (Renewed) - $299.95
 
You can run PFSense on any two port or more computer.
 
Here run it on a 6 Intel Gb port computer as I utilize a T-Mobile LTE modem as backup to the ISP connection.

Over the last 20 years and documented here on the CT and Homeseer forum were HAI OmniPro 2 NIC port issues. Old designed network port which had issues with newer networks (10Mbs1/2 duplex port). So here put a micro router in front of the NIC port inside of the HAI can which isolates the network port on the OmniPanel.
 
FAQ:

Microrouter DIY for use with the Omni Pro Panel Ethernet port
 

LarrylLix

Senior Member
Devices will sometimes factory reset to weird IP addresses so they do not conflict with existing LAN structures. They expect you to change the IP address and your IP allocation range to a more acceptable IP address range to suit your existing LAN.
 
Make sure your IP allocation range is set along with your subnet mask of 255.255.255.0, and for Gawd sakes install that static IP address into your router IP reservation table so it doesn't conflict with another device, and crash your whole network at some inopportune moment  in the future, leaving you helpless and wondering why.
 
If you are connecting via 5GHz on an ASUS mesh router, you may not get more than a few feet out of it. Try the WiFi6 (5GHz AX) band or 2.4GHz band.  It seems like they are trying to discontinue usage of 5GHz on ASUS meshes. My Roku Stick wouldn't stay connected at all at 12 feet away.
 

pete_c

Guru
Devices will sometimes factory reset to weird IP addresses so they do not conflict with existing LAN structures.
 
Not the HAI Omni Pro panel as it uses Ethernet technology from the 1990's.  The IP configured on the panel will remain the same no matter what network it is connected to.  No DHCP and only 10Mbs / 1/2 duplex.  That and the HAI built in NIC has design flaws (promiscuous NIC which takes down the serial based HAI panel)  in it because it was designed to work on a 1990's style Ethernet LAN.
 
Today's SOHO router (whatever is over the counter sold for residential use) combos are a bit better than yesteryear's combo routers.
 
Tinkering here have always replaced the SOHO router's OS with OpenWRT (levels above any MFG OS) just to tinker.
 
Helping an automation peer in LAS using same Asus combo router. 
 
It is very primitive and limited in functionality with large eye candy dysfunctional and colorful icons similar to Windows 10 / 11 desktop or Mac desktop.
 

abbachia

Member
quick update...
brought the old router back on line...went through all the LAN settings and firewall setting..everything matches the new router
still non luck..
 
in an interesting twist..
 
I can ping the IP address of of the OPII even though it doesn't show on my router's client list !
 
This is really starting to make me nuts!
 

pete_c

Guru
The OPII does not do DHCP and will not be present on any new or old routers client list.
 
Do you have the HAI PC Access program?  
 
Do a screen print or picture of the IP and key configuration on the OPII (block out you key configuration). and post it here.
 

abbachia

Member
ok solved...
spoke to my office IT guy...he's like..yeah..static IP not going to show in the client list.....you need to do a manual add..
 
brought the old router back up...copied MAC address.....manually added MAC address and plugged the IP and viola..
 
sorry if you all assumed that i had tried that...
 
much thanks!
 
not sure how long I'm going to hold onto this system...antiquated technology....no updates etc..
 
what is the best alternate HUB that would interface with the OPII so I can leave the infrastructure/UPB switches in place and just a have a more up to day interface smoother web access etc?
 

pete_c

Guru
Just write down the IP , subnet and DHCP reservation list from the old router and configure the new router with same.  You should be fine after that.
 
Top