HAI/Leviton Omni LTe - Connection Help


After a power outage, it seems my IP address has changed (I guess this is normal?) and now I can't connect to the Omni.

This happened a few weeks ago so I Googled my IP, typed it in the Snaplink app and I was able to connect while offsite. Now, I can't get it to connect at all and I'm thinking I may've left a step out.

Would it be possible for someone to walk me through the steps? You may need to dumb it way down for me. I don't think it's a port issue as I can see the Omni in my very old but somehow still operating Apple AirPort Extreme router.

Thank you!!
  1. Are you trying to connect to your panel from inside your network?
  2. Can you confirm the IP address of the Omni is still the same (trying pinging it from the command prompt)?
  3. Have you tried rebooting the router (in case the WAN ip change messed up the hairpin NAT handling)?
Well, now it's working.

I Googled my IP again, noticed it was a different number than a few hours ago, and typed that number in the Snaplink app as well as in PC Access under Options>Network and everything worked. I did nothing different than earlier today. So annoying. I really wish I knew what went wrong.

I was able to connect my iPhone Snaplink app and PC Access on my PC to the Omni from both my home WiFi as well as my mobile cellular (w/ wifi off).