OmniPro Issues AGAIN!


Back at it again, lol more money more problems i guess LOL.

So I posted before about intermittent issues with the panel, initially i assumed it happened after our modem was replaced and we're still working to get a different customer owned modem in our church to see if that will fix it.

We recently did a job in our sound room, and replaced all of the networking equipment in our room to TP-Link/Omada equipment and we're now getting literally no connectivity on the panel.

This is how the system is setup now

Modem(Bridge Mode) > er605 v2 (Router) > TL-SG3428 v2.0 (Managed Switch) > Panel

Also connected to the er605 is a Omada Controller thats being used to manage the router and switch.

I'm able to see every device thats plugged into the switch by the IP and its corresponding port number. On the switch where the panel is plugged in its plugged into port 24 and there are activity lights going on that port but Omada doesn't have an IP listed nor is the port listed in the clients list.

Lol HELP! Lol i'm at my wits end with this thing, and the next step is to take it off the wall and check the port (which is what i shoulda done from the jump but was trying to avoid it)
Can you change from using Bridge Mode to putting the ER605 v2 in to a DMZ. Many many years ago I had issues with the combo Verizon FIOS box bridge mode and at that time just put the IP I needed for the firewall in to a DMZ. Worked great.

Modem (Router IP in DMZ) ==> ER605 V2 ==> Switch Port (set to 10Mbs) ==> Panel.

I use a micro router between the OP2 panel and the rest of the network (Using all TP-Link managed switches here and one TP-Link L2/L3 managed switch). You can try to configure the OP2 Ethernet port on the switch to 10Mbs or use an old Ethernet Hub instead of the micro router.
Okay sorry for the super late reply. But i reset the router took it outta bridge mode, put the IP of the ER605 in the DMZ and set the port to 10Mbs Auto, here are the settings in the switch for that port you let me know if theres anything that i'm missing, no changes yet and no ip address.

the last picture is all the last list of ports. It should be 24 but its not there at all.


  • settings1.PNG
    20 KB · Views: 5
  • settings2.PNG
    18.1 KB · Views: 5
  • settings3.PNG
    15.7 KB · Views: 5
If you cannot ping the OP2 address via the switch or direct connect then more than likely your Ethernet port has failed. There are a couple of third parties out there today that may be able to repair it.
We're going to direct connect to it today and see if we can ping it and then I can answer that question. But on the status of the port I get download traffic but no upload traffic.
Okay so some new developments. We pulled the board forward out of where it was being held and was able to test continuity thru the pins on the back against a cat6 cable plugged into the port using a meter and all the pins are fine. Both Lan and act lights are working and are moving as of normally but still no IP address.

We did some testing on the LAN Pulse Transformer on the circuit board.

Transformer is giving continuity, all leads check okay, but weren't able to test accurate impedance of the transformer.
What you want to check first is the local transport. If the local transport works then the firewall to the Internet transport is a non issue.
Very good.

Make a hand drawing of the transport and post it here with MFG name and models. The images above are tiny and difficult to read.

Modem(Bridge Mode) > er605 v2 (Router) > TL-SG3428 v2.0 (Managed Switch) > Panel

Put an IP in a DMZ and use that IP for your ER605 router. Is the modem a cable model or DSL modem?

How many devices are on the same network?

The Ethernet port on the OP2 sees everything and works at old 10Mbs and cannot deal too well with lots of traffic. IE: it gets "constipated".

Fixes are to put in an old hub between the OP2 and rest of your network or my solution of a microrouter. (any router will do).
I hope this is what you were asking for, im not sure apologies about the delay been trying to fix some other stuff in the church.

Put an IP in a DMZ and use that IP for your ER605 router. Is the modem a cable model or DSL modem?
It's setup in the DMZ with an IP address, its a cable modem.

How many devices are on the same network?
The Panel is going thru a smart switch, there are approx 20+ devices on the network

The port that the Panel is plugged into is setup on 10 mbs auto.


  • IMG_2740.jpg
    1.5 MB · Views: 0
Note putting the IP in a DMZ has nothing to do with your basic OmniPro LAN connectivity and only relates to external access to your OmniPro panel.

Is there a computer on the network that is on 24/7?

Try a continuous ping to the Ethernet port on the OmniPro panel. See if that changes over time (1,2,3 hours).

Make sure that the panel's IP is not in the DHCP scope of the router / firewall.

What we are looking at now is for a stable network connection to the OmniPro panel.
Last edited: