• You've been granted Beta access to this site, allowing you to explore some of the new features while they're still under construction. More information can be found in the Beta forum.

Problem with light control on an HAI Omni 2E

pete_c

Guru
I only use X10 these days for the Christmas lighting.  I put everything outdoors and indoors on one house code here (A5).  I went to LED lamps one year and it was low on the WAF.  Never tried to dim them and switched back to incandescent lighting (large C9's which are difficult to find these days and break very easily).  For the Christmas tree went to antique (circa 1960) illuminated candles.
 
From a post circa 2014 see this:  LED Bulbs that work well with X10  (Read 22708 times)
 
X10 switch design has not changed in over 20 years. 
 
My first generation of LED bulbs that were supposed to dim were only OK with the UPB switches.  Newest Generation of dimmable LED lamps work much better today with UPB switches.  I am now at around 100% LED lighting.  Relating to automated lighting do not automate bathroom or closet lighting; never have.  I have friends that have replaced every in wall light switch in their home with automated switches.
 
Testing Tasmota WiFi dimmable switches these days.  These work fine with LED lamps.  BUT the OmniPro 2 panel doesn't speak MQTT.
 
You can try replacing your X10 stuff with UPB, ZWave or Zigbee.  For UPB you will need an HAI UPB PIM.  For ZWave you will need a Leviton (HAI) VRCOP PIM.  For Zigbee you will need a Leviton ZIM module.
 

ano

Senior Member
pete_c said:
I only use X10 these days for the Christmas lighting.  I put everything outdoors and indoors on one house code here (A5).  
LOL I do that also, but have some newer lights that have Bluetooth and their own app.
 
Top