RCS Tstat Software Error


Active Member
I just bought an RCS thermostat (TR40 - RS485 communicating) and a ZCV4
series zone controller (again RS485 communicating). RCS also supplies a
software CD with the Tstat.

According to the software documentation, you must use a RS485 to RS232
converter for the software to "see" the Tstat. I have done this and I am
able to "see" the Tstat and the zone controller (and each of the zones that
I have connected up). The software has a logging feature that allows for
graphing of system temps and operation (run time, damper status etc).
However, after a minute or two I get a repeated single error (about 2 per
minute) when I let the software run to log system status. The error is:

"Error #9 Subscript out of range".

I thought this may likely be caused by the Tstat addressing (the zone
controller likely has fixed addresses numbers 1-4, while the TR40 address
can be set to address #5.). I tried many variations of addresses with no
success. Has anyone been able to get the RCS supplied software to fully work
without this error? Any ideas what it may be? Please see my original tech
support message to RCS. I thought it was well worded (maybe not???). Then
read RCS's answer.

Form your own opinions.


The RCS TCP program is supplied as a means of confirming Serial connectivity
in a thermostat network. It is a tool and not a supported program for
network control or scheduling.

RCS, Inc
To: [email protected]
Subject: RCS Tstat Software Error: Ver 6.06.04

Dear Sir,

I have recently set up (benchtop only) a ZCV4 controller (w/ a TS16 and TS40
WDU) and a TR40. These will be for a new house under construction.

The house will have 2 AC/Heat units. One will be controlled by the TR40,
the other will be controlled by the ZCV4. The present design calls for two
zones on the 1 HVAC unit, but may likley expand to 3 zones (hence the ZCV4).

I have just set up a RS 485 network for these units. Using a RS 485 to RS
232 converter, I am able to "see" and communicate through the RCS software
to each zone of the ZCV4 (just the two that I have WDU's attached to), and
also to the TR40 unit. However, when I leave the software open to the Tstst
tab (to keep the logging enabled), after a short amount of time (a minute ot
two), I start to get:

"Error #9 Subscript out of range"

I have tried re-numbering the network addresses, but that does not seem to
fix the error. Any suggestions?

P.S. As a side note, the RS485 network interfaces FLAWLESSLY with the Elk
M1XSP serial port expander module..... making RCS a very attractve Tstat
and/or zone controller option for folks like me who really like the Elk

Best Regards,