Trying to run Amazon-HA-Bridge on my Freenas....trouble ensues


Active Member
I haven't received any traction on the Freenas forums....they aren't as friendly as here either  :(
Here is my post over there...
But in a nutshell, I created a jail, installed java and got the HA-bridge running.
I can access the web interface on 8080....but Alexa can't find the bridge ( i suspect the UDP ports are blocked somehow)
When I run sockstat -l4 on the jail, I get....

root java 21355 27 tcp4 *:8080 *:*
root java 21355 32 udp4 *:50000 *:*
root java 21355 33 udp4 *:1900 *:*
root syslogd 6673 7 udp4 *:514 *:*

I thought I'd ask here, as it was cocoontech that sent me to the Freenas platform when I decided to finally leave WHS.
My feeling is my Freenas box has lots of horsepower that is not being used, so i'd prefer to have less pieces running and migrate anything I can to a jail...this is my first step and I'm currently stuck.
Also, i have run and can still run the bridge on an Rpi or windows PC on my network, Alexa finds the "bridge" without issue. So I believe it is a Freenas/jail issue that I have just missed ...
Thought maybe you could get help there. 
I built my 8 drive NAS4Free box a couple of years back and its been working fine and all I have done is update it.
Post a step by step for me and I will give it a try here.
Here are my current specs:
Version - Prescience (revision 1761) Build date Sun Aug 9 23:27:32 CEST 2015
Platform OS FreeBSD Revision: 199506
FreeBSD 10.1-RELEASE-p17 #0 r286526M: Sun Aug 9 16:49:07 CEST 2015
Platform x64-embedded on AMD E-350 Processor System ASUSTeK COMPUTER INC. E35M1-I System
8 Gb of memory averaging maybe 10% sometimes.
Also went with an IBM M1015 SATA controlled flashed to a LSI 9211 IT.
I went to using the Alexa and MS Kinect Homeseer plugins and have shut down my Amazon Alexa these days.
  1. Created jail called automation and add some storage in the pool (point it to /media
  2. ssh in to Freenas server 
  3. type 

  4. type 

    jexec automation tcsh

  5. type 

    portsnap fetch extract 
  6. type

    cd /usr/ports/java/openjdk8 
  7. type 

    make install clean 
     ( if you get errors, you may need update some of the ports to get openjdk installed)
  8. type 

    java -version
       to test your installation  (if there are errors, work thru them to get java working)
  9. type 

    cd /media 
  10. type 

    mkdir echo
    cd /echo 
  11. type 

  12. type 

     java -jar /media/echo/amazon-echo-bridge-0.2.1.jar -upnp.config.address=
        where your is the ipv4 address of your jail
  13. Watch the output for errors (there should not be any)
  14. Open a browser and enter
  15. This should load the interface to the bridge...enter a device and click load..
  16. Ask "Alexa, discover devices"
  17. Wait for her response
This is what i've done, and everything works great until i Alexa searches for devices.\
Just noticed that I am running NAS4Free rather than FreeNAS.  It is a bit different than FreeNAS.
That said I have another box that I was running FreeNAS on and it is current in the off mode.  I will update FreeNAS on it and utilize the jail plugin.
I have solved it. 
I changed the Upnp listening port to 50099 instead of the default 50000 and that seems to have done the trick
Good news Project_x.
I knew you could do it.
I set aside the old freenas box here but never got to it.  Probably cuz my Echo is off and went to playing with the Alexa application.
I then started / drifted off to work / play / tinker with a squeezebox like application that boots off a USB stick and runs in ram.
It is very unique software.  The author is in Finland.  I have modded the EFI booting stuff on it so it is working fine with my touchscreen tablets.
pete_c said:
It is very unique software.  The author is in Finland.  I have modded the EFI booting stuff on it so it is working fine with my touchscreen tablets.
Curious, the FAQ specifically calls out that it doesn't work on a Raspberry Pi.  Given how inexpensive and flexible they are you'd think it'd be a no-brainer.
Yup; it is Intel CPU based.  It has some very granular audio hardware controls.
Using it on the O2 Openpeak Joggler.  Just had to adjust the EFI boot files.  It also includes a SqueezePlayer front end which works nicely.