HAI Omnitouch Update Problem

Need some help if possible (HAI is away for the weekend). I was updating an Omnitouch 5.7 to the latest firmware and all seemed to go well until the reboot then I got a "System Error Update Error" message. Tried to do a reboot and can get to the point of selecting the upgrade file again but the touchscreen has lost its ability to touch - therefore can't input. Any ideas to reset / reboot / etc.

I'm having a similar problem today. I am updating the firmware with a USB thumb drive, but when I connect the drive and press reset, the 5.7e touch screen goes black and shows "SYSTEM ERROR UPDATE ERROR" in yellow letters. If I remove the drive and press reset again, it will go back to normal operation, but I really want to upgrade the firmware.

Not sure anyone will be listening as the original post is 18 months old, but I figured I'd try....
It is possible/likely that the update file on the thumb drive is corrupt.

Try downloading it again.

Use a thumb drive that is less than 4 GB and formatted in a FAT file system. FAT12, FAT16 and FAT32 should work fine but the touch screen can not read NTFS formatted thumb drives and though I have had reports of > 4 GB drives working none that I have personally tested worked.
I ran into the same issue as "scottm" when I tried to update my 2 Omnitouch 5.7 screens where the touchscreen was hanging at the point of starting the version update and would not respond to touching the "Enter" icon. After many hours of troubleshooting, I discovered that some parts of the screen were responsive to touch. So it appears that there is a mismatch between what's represented on the display and the actual input areas (HAI, please fix this).

The actual area of the screen that you need to touch is over in the LOWER LEFT quadrant of the display (even though there's only blue screen in that area). Be patient and use only your fingernail to probe around that area to initiate the update. There is also a "Cancel Update" action very close to "Start Update" action in the same area and if you happen to hit that area, you will need to press the reset button on the OmniTouch 5.7 to try it again. Once you have successfully initiated the "Start Update" process by touching the correct part of the screen, you will then be asked to touch the screen to begin the update process. At this point you need to touch an area in the UPPER LEFT/MIDDLE quadrant of the screen to start the update process. Once you find it, your update will begin and then pull the USB stick out of the OmniTouch and press the reset button and you will be back in business with the new screen version.

Remember to use only your fingernail when probing for the correct areas of the screen to touch because there is not much room between the accept and cancel inputs and you may have to try a few times before you get it right. Hope this helps and save you the many hours I spent trying to get this update loaded.

- Tom

I have not see this problem before and of course we program thousands of touch screens in house...

To me it sounds like the calibration is way off on your touch screen. You can recalibrate the touch by momentairily pressing the reset button then immediately pressing and holding the lower right corner of the screen until you see the screen enter the calibration mode. This may take sever (30) seconds. Press each of the 5 touch targets when presented and the screen will be recalibrated.

Finally try the update again.

Please let me (and everyone) know how this worked.
I was having a problem with portions of my touchscreen not responding so I tired the calibration and now the thing is even more messed up. I also can't update because the keys are not responding. I've tried calibrating several times. Only some areas work and none accurately. Maybe I'll trying tonight in the dark incase its too bright now. Not sure what else to do.
Portionf of the screen not responding does not sound like a calibration issue...

You should contact HAT technical support. They can help you troubleshoot the problem quickly and get you running again.
NOTE: After trying to calibrate the screen 10 or more times with my finger tip, I finally tried with the tip of a pencil eraser. After having the screen all messed up and even had HAI said to send it in- the thing now is back to normal with no problems. I even had an RA number. No one thought to ask about how I was calibrating, and the screen on the touchscreen just says touch each area. I would call that wrong. It turns out you are suppose to hit the tiny crosshairs ONLY within the tiny box. There is no way to do that with a finger. HAI website should mention that or even the manual with the touchscreen. I only heard about calibrating from HAI_fjh above. Thanks for the info.
Yup; here I have only calibrated the Omnitouch 5.7 and Omnitouch 5.7e's once or twice and never really paid much attention or had issues with the calibration methodology.
If I see wierd stuff then I just hit the reset button.  The Omnitouch 5.7e's take longer to come online that the Omnitouch 5.7's.
A few years back I did mess up my Omnitouch 3.5" serial touchscreen.  I did try to replace some smb parts on it myself to get it working but never did.  The screen kind of works but doesn't boot into the OS.  It is considered legacy and not supported anymore. 
Or try going into *some* amount of detail if you'd like more help... help us help you; describe what you've done, more about the symptoms, etc.
i try to caliprate
the tech suport told me to press the small  hai house at the power on
i am trying this but nothing is going on.