hooking up my SECU16 to my Ocelot

electron

Administrator
Staff member
So I finally rewired my computers, and have the chance now to connect my SECU16. I have power, and COMM A&B hooked up, I have a solid red light, and a blinking red light. I loaded Cmax, and tried auto addressing the module, but nothing happens, it just sits at "Module #1 ... skip/abort". While this is on the screen, I hit the button on the SECU16 unit, but nothing is happening except the blinking RED starts blinking slow now. What am I doing wrong?

Last but not least, I am planning on just hooking up some magnetic reed switches, do I need the 1k resistor if I am not interested , and if I do need it, how do I hook it up (pictures would be great). Thanks guys!
 

Guy Lavoie

Active Member
Try holding down the button in the SECU16 for one or two seconds. The blips on the comms LED of the Ocelot indicate that its looking for the module to respond. Also make sure that you wired A to A and B to B between the modules.

Yes, you do need the 1k resistor. you would normally connect the resistor across the contacts of your reed switch, in parallel with its connections to the SECU16's input and common terminals. Thus the input sees a short when the contacts are closed and 1k of resistance when they're open. If you are using normally closed (alarm style) contacts and you want the SECU16 input to "turn on" when the contacts open, then you wire the 1k resistor in series with the reed switch and the SECU16 input (and the other side of the reed switch goes to the SECU16 common as usual).
 

BraveSirRobbin

Moderator
electron:

Make sure you do NOT have homeseer trying to access the Ocelot. Start CMax and click on "Attach to Controller"

You will then see the menu below.

Click on Auto Address Modules (Under the "Module Utility" option)

A red dialog box appears

Wait approximately 30 seconds

Hit the Auto Address Button on the Secu16 (hold it down for about two seconds).

Then click Abort on the red dialog box.

Wait for the controller to restart.

You should now see the SECU16 in the right hand box and its current values

Try manually setting a relay to make sure it works (again under the "Module Utility" option. I also place a 1K resistor between the channel input and ground. You should see the ON value. Then short out the resistor with some clip leads. You should then see the OFF value for that channel.

BSR
 

Attachments

  • cmax.jpg
    cmax.jpg
    56.3 KB · Views: 10

electron

Administrator
Staff member
I did that, and it rebooted just as you said, but there is nothing listed in that table.
 

BraveSirRobbin

Moderator
OOPS:

Sorry Guy, I see that we replied the same time! Didn't mean to repeat what you said.

Electron, make sure you WAIT 30 seconds from when you click on "Auto Address Modules (Red dialog box appears staying at "Searching For Module 1") BEFORE you press your SECU16's address button. Make sure you hold the button down for a couple of seconds. You should then see the red dialog box increment by one (It should state "Searching for Module 2"). Then click on its "ABORT" button.

Controller will hopefully restart and you should see the SECU16 module's channels and present values.

If not, maybe give me a call (at home) tonight and I'll help you trouble shoot.

BSR
 

Guy Lavoie

Active Member
Hmm, doesn't look good. Was everything powered off when you connected the module? There is always a risk of blowing the comms chip if tis connected with the power still on. If these are your only two modules, then it won't be possible to have you try swapping comms chips. If you have an electronic parts supplier close by, you can always get a few 75176 chips. These are only about $1 each.

Try holding the button for several seconds, and maybe check the continuity of your bus wires by powering off everything and using an ohmmeter to look for a good connection between each screw terminal.
 

electron

Administrator
Staff member
I unplugged the Ocelot when I hooked up all the wiring, but the one thing I didn't do is wait 30 seconds before hitting that button, so I am hoping that's the mistake I made. I won't be able to test the terminals until I get home, but it's something I will do if the 30seconds thing doesn't work, and hopefully I don't have to swap those chips out. Thanks again guys!
 

electron

Administrator
Staff member
Ok, I tried this again, and I enabled error logging. It is still stuck at "Looking for module #1", so I hit skip to have go to module #2, and I get a "Comms retry timeout 101 RX3" and "Comms retry timeout 101 RX1". I don't know if this error was generated because there is an issue with module #1 or because there is no module #2. I will have to check the wiring when I get home I guess.

edit: after trying to skip a few more modules, I didn't get any more of these errors, so it must be related to the first module.
 

Guy Lavoie

Active Member
Well, the "Comms retry timeout ..." errors come from a RS-232 problem between the PC and the controller. This is not related to any comms errors between the controller and modules (RS-485). I'm beginning to think that you really do have a bad RS-485 chip if you cannot see the SECU16 at all. If you could a hold of another SECU16 (or any other module) then you could at least try and see if one of the RS-485 chips is bad. These are 8 pin DIP parts and plugged in sockets (except for bobcats, which use soldered, surface mount parts).
 

electron

Administrator
Staff member
I am hoping that I made a wiring mistake, eventho I am pretty sure I didn't. I will report back when I get home and look at it myself. Thanks!
 

electron

Administrator
Staff member
After rewiring it several times, it started working all of a sudden, so I am all set, I have the garage door hooked up, the 1k resistor is about 6" away from the magnetic reed switch, everything works as advertised. How hard is it to hook up my garage door switch to an output? I believe there is about 6VDC on the line going to the switch.
 

Guy Lavoie

Active Member
Using an output to activate a garage door pushbutton switch has been done by others. The only thing is that its best to verify the current going through the switch when closed. You could do this with multimeter set to measure DC current (a scale with range of about 500 mA would be good). Make sure you observe the polarity of the voltage in connecting the meter probes. If the 6V activates a small relay, then it chould draw anywhere between 30 to 100 mA or so. There has been some recent discussion on the ADI forum about the use of SECU16 output relays to control any inductive loads (even small relay coils) and BSR can tell you of his experiences in this application. Sometimes the relay sontacts stay closed even if the relay is turned off and needs to have the load's power disconnected to open again. It seems the reed relay contacts get magnetized. The best way to find out is by experimenting with your particular load.
 

BraveSirRobbin

Moderator
electron:

I believe I gave you some 24 VDC relays and a 24 volt power supply. I would use those. I can create a schematic if you want. Let me know.

BSR
 

electron

Administrator
Staff member
I will have to take some measurements when I get home, then you guys can tell me what will and what won't work, I was hoping to avoid using another power supply.
 

jrfuda

Active Member
I use an SECU16 output to control my garage door. I wired it directly without any relays and it works great. I have a craftsman opener with the "deluxe" contoller. It was very easy to do, all I had to do was add my wires to the 2 screws that held the original 2 wires going to the opener.

THIS IS VERY IMPORTANT!!! If you're using the SECU16 to control the door, make sure you put in some CMAX code or an HS event that will open the relay if it is closed (For good measure you could do both). If you don't do this, when you close the relay to trigger the door toggle, the relay will remain closed and you won't be able to control the door from anywhere until you open the relay again.
 
Top