setting X10 for Icon Switch


i have an insteon ICON On/Off switch attached to a light. I am trying to set its primary x10 address and cant get it to work. the instructions say to press and hold the top of the paddle for 10 seconds until the led flashes slowly. this part works.

then it says to send the desired x10 address 3 times. and when it accepts the address it will flash the led and the load. this is where i am having problems. i tried sending the x10 address from the RF remote, from homeseer, from my tester devoce... none seem to work. the switch never receives the address setting.

am i misinterpreting the procedure for setting the x10 address or is there some other problem i am unaware of?

any help would be greatly appreciated.
From the sounds of it, you are sending the device code + the on or off comand. You need to just send the device code, such as M13 or something. The palm pad send M13 plus then on or off command. If you have a maxi controller you can try that otherwise you can click on the control tab in Homeseer, enter the address, and click the Address Only button.
I haven't set any X10 addresses to my Insteon stuff, but in the manual it says that sending the command after the address is optional, but allowed. The time when you can't use it is setting custom ramp rates or on levels.
I have with a Palmpad no problems on Icon or Insteon switches and modules.
For the Appliance and Dimmer Modules. You use the address and an ON for local control and an Off for ignore local control.
Ramp rates and scenes [not in an Icon] as mentioned do need address with no on or off code.
The MaxiController is so nice that way. Built in code sequences for things like add a scene or ramp rate.
If you have a lot of X-10 traffic in your house maybe something else is going on at the same time that you are trying to set the code. If a command from another source is seen between one of your transmissions it will mess up the process.

I use a Maxi-controller plugged in as close to the switch as possible so I can hurry up and transmit the code sequence before something else on the line messes it up.
Good point on the traffic. I believe sometimes mine programmed with one or two send button pushs. I bet it saw a reflection from my Repeater.
MaxiController close outlet sounds better.
hey thanks for all the replies. so i went to try controlling one of my lights like i normally do from my IR remote via IR543 and it did not work. ever since i installed the icon switch and the insteon switchlinc, the other stuff has not worked.

i think what is happening is that the signal cant get from my stuff upstairs to my homeseer pc downstairs, and vice versa.

the question is why would installing a couple insteopn switches make my other stuff stop working. i know they are installed correctly because i had my electrician install exactly according to the diagram from the directions. plus the insteon portion works fine and the local control of the load works fine.

any thoughts?
All Insteon and Icon modules and switches are two way devices. They can transmit signals back on the power line. The transmitter circuit; if not the one transmitting can absorbe some of the signals on the power line. Two way X10 modules and controllers; also can absorbe signals
hmm - ok good to know - i have a boosterlinch plugged in somewhere already perhaps i need to relocate it.
ok so i tried relocating my boosterlinc to just about every outlet in the house and it seems to have no effect - the switches upstairs still cant communicate with homeseer downstairs and vice versa.... now what?
are they on the same phase as the controller? did they work before insteon? do you have a coupler that might have gone bad
ok - turns out i am just a dumb a$$. after installign my new insteon switches, i downloaded the insteon plugin for homeseer - and didnt even think abotu the fact that i hadnt ordered the insteon pc interface device. so i had downloaded and enabled the insteon plugin which disabled my cm11a interface in homeseer.

i just went and disabled the insteon plugin and enabled the cm11a interface and i am back in business. i cant beleive i did that :D

one more question though. in homeseer - setup - interfaces the insteon plugin there is an x-10 and an other column which can be enabled. does this mesn that if i have the insteon interface device i dont need my cm11a anymore?
Beware, The Insteon PLC does not handle X10 commands very well, it is recommended to use your old interface for X10 and the Insteon PLC for Insteon devices.