Upstart USB CIM SAI will not connect


Senior Member
Have you tried plugging the CIM into a different AC outlet? After reading thsi thread I tried communicating with my UPB system for the frist time in a very long time. It failed.
I first thought that it might be Windows 10 upgrades causing the problem but then it occurred to me to move the CIM to a possibly quieter AC outlet. With the new outlet I was able to connect to seven of eight devices so the problem here is noise.
Try moving the CIM around the house and see if it helps.


Senior Member
Also note that a Simply Automated PIM (UPB Gen 1) has some restrictions when communicating with UPB Gen 2+ switches over a repeater to switches on the "other phase."  You can generally control these switches, because that is a one-way action, but UPStart will not program them (using a Gen1 PIM) because that is a two-way action which will fail.  If UPStart can communicate with some switches and not others, AND you are using a repeater, that is likely the problem.

By the way, the PCS PIM is excellent. The strongest one out there.


I am having trouble getting Upstart to connect again.  I keep getting the red X next to Get Firmware Version with the message, "The powerline interface could not be found.  Check that you have the interface powered-up and that the cable is properly connected between it and your computer {32}
Is there a firmware label on your SA CIM? 
Earlier tested it to work fine with Windows Standard server 2016 64 bit using Upstart V111.
Just tested the SA UMC-USB-W pictured above with firmware V419 as mentioned above on Windows 10 64 bit updated to current release then updated again to current insider release.
Used USB 2.0 and USB 3.0 ports with V111 of current Upstart application.
Worked fine for me.  It is coming up as OEM and firmware version posted.
Odd here that when I plug in the device it states it is loading a USB to serial device.  When I look at the devices I do not see any serial devices and just two added generic USB devices.
Tested it in the kitchen plugged in to nearest outlet.  It saw all of my UPB devices just fine.
...I just ordered the PCS version of the USB.
As mentioned above both of the PCS versions of the UPB PIM are serial device.
The PCS USB device has a built in serial to USB converter.  After installation you will see it under devices.

As Ano mentions above you will be fine with your new PCS UPB USB PIM.


Pete....good news.  I received my PCS USB PIM today and it works!  However, I got it connected via the USB PIM (virtual serial port), instead of the USB CIM (SIA), which is what the representative for Simply Automated told me.  
Anyway, I'm connected and running!  whooo hooo
One thing different from my last USB PIM though...whenever sending commands, the part the plugs into the outlet makes a buzzing sound.  My old one never did that.  Is that normal? 
pete_c said:
Good news CajunHAI
Been playing here with UPB for over 10 years now and have multiple UPB PIMs.
IE: HAI, PCS and SA.
The SA CIM worked fine this morning. 
But historically the only UPB PIM that has given me issues has been the SA CIM because way long time ago it used propietary USB drivers in Windows.
This is where a long time ago switched over to using only PCS USB or RS232 and HAI RS232.
Today with my Omni Pro 2 panel only utilize the HAI UPB PIM. 
I also utilize a HAI/PCS UPB repeater here which works well as I have 100% coverage today of my UPB switches.
My UPB floaters are HAI and PCS plus the SA CIM I mention.


Active Member
Some of my UPB PIMs buzz when sending commands.  That sounds normal for the PCS unit, which is the higher power of the PIMs.  I'm curious if others hear the same, I just figured it was normal.