Can not connect to my OmniPro II


Last week, when I updated my automation program with a new block, I checked off all but the Extended box, and hit send and then looked away. About 2 seconds later. I looked back and I was expecting to see it deleting the old program but it said, I believe “Waiting”. I had never seen that before, in 20 years with the system. After a few minutes, I rebooted the computer to try again. I got a TCP 201 error. I believe there is no program in the OmniPro II. I guess it finally went to delete the old automation and setup, but it never got the updated one as I was no longer connected. Basically, I have no automation or OmniPro II.

Can someone tell me how I can get communication back with the OmniPro II? I have not gotten the OmniTouch 32A00-5s back up yet, either. I have been using PC Access and Myro. Myro doesn’t do anything because the is no automation in the OPII.

Any assistance would be greatly appreciated!

Thank you.
Hi gym4im,
Have you tried to connect with the serial port? USB to serial port adapters are cheap. You can verify verify the automation using the console. Is the 32a00-5 your only console?
Even with no automation on the OPII, Myro should still be able to arm/disarm, show zone status, show temps, etc. If your network connection is broken that is why Myro is not able to do anything.
You are correct about Myro and I can see those areas. I use Myro mostly for lights and A/C. Inter-action with security is primarily handled with access keypad and door lock. Thank you for suggesting the USB/Serial connection. First I was going to try connecting directly with an Ethernet Cross0ver cable. Do you think that is worth trying? Really curious as to what may have caused this.

I also have been focused on other items of readying the house for sale, with a contractor, so I haven't had a chance to make a cable to try your previous remedy for my Omnitouches. I did have a keypad that never got mounted. Need to hunt that down!

Thank you for you suggestions....Will let you know.

First I was going to try connecting directly with an Ethernet Cross0ver cable. Do you think that is worth trying?
Yes, its worth trying. Remember you have to manually set the ip on the pc to be on the same subnet as the OPII.
Yes, its worth trying. Remember you have to manually set the ip on the pc to be on the same subnet as the OPII.
You are 100% correct. Myro does report those items. It is only that the automation, connecting to the OPII, and using buttons and controliing light does not work correctly.

All of my items were originally set up on the same subnet, and still are. They are on a WRT Linksys router which is cascaded down from my Assis BGW210-700 AT&T Router. The Linksys is the only item on the Assis.

I did try the cross-over cable. Unfortunately, the cross-over cable, I made a while back, was not long enough, so I coupled it with a straight through cable. I had read, or someone told me, that the cross-over would still work. I would image it would as it would be like extending the ethernet port, of the computer, to the middle of the room to connect to the cross-over cable.

I am still looking for the regular keypad for the system. In the meantime, I can get a USB male to RJ12 to connect to the open serial port on the main board. As long as it says it is serial and it is a RJ12 connector, I should not have a problem as far as getting a correct cable, correct? There seem to be a lot of cables, of similar descriptions, with chip sets in them and are for cameras, or handset, etc., which can confuse.

Last week the controller did stay connected for a few minutes and I could control a light, temperature, etc. But then it crashed as soon as I tried to communicate with the controller by re-downloading the automation program. In 15 years I have not had a problem!

Thanks for the update.
You need 2 cables for the serial connection. The one that came with the OPII which is a 6 pin rj12 to DB9F, Then you need the USB to DB9M adapter.
Old USB 1.1 serial adapters work fine. Buying a brand name adapter should help narrow down the choice. Keyspan was a reputable vendor.
Have you tried disconnecting everthing on the Assus except the OPII and the AT&T router? If that works, you should look into Pete's fix to isolate the OPII on its own switch.
Mine always says "Retrying..." during the erase cycle. I think it's because I have 990 lines of code loaded; it takes longer than the timeout period to erase. But it always works eventually if I leave it alone.
I am having the same problem with my OP2. Got the Leviton guys to help me troubleshoot, and it comes down to something is wrong with the circuit board. My ethernet to the board is fine, all the settings are correct, have tried alternate ID addresses as well as Port #'s, but the circuit board just won't pick up the request. This problem started out more than a year ago with the OP2 taking multiple tries to make a connection, but it was always eventually successful. About a week ago I couldn't get it to connect at all. Started talking with Leviton techs, with no luck, but just for about an hour or so, had a successful connection. I thought it was from cycling from one IP address to another, then back again. But the success was short-lived and now it's dead. I've used the crossover cable direct connection method and got the same result - "timed out (10060)".

Any ideas anybody? Any HAI OmniPro2 repairmen out there? Any new OP2 boards out there anywhere? Any suggestions about a retrofit?
I'm amazed by that. Leviton has techs that know about the OP2?

You can still occasionally find boards on eBay when they are taken out of service.