How to monitor quality of internet connection?

For DNS settings go to System==> General

Here just using and

Here are my results...similar to yours...

2 (  11.759 ms  11.674 ms  8.044 ms
 3 (  8.189 ms  11.791 ms  7.838 ms
 4 (  13.201 ms * *
 5 (  16.032 ms  11.986 ms  10.460 ms
 6 (  17.821 ms  37.020 ms  13.286 ms
 7  * * *
 8  * * *
 9  * * *
10 (  12.364 ms  12.757 ms  11.671 ms

Do you have IPv6 configured?

To test IPv6 after you have it configured go to

Test your IPv6 connectivity

Here have the Snort add on configured but not Squid at this time.

For the ups and downs do some more long term testing on dslreports dot com.

What speed tier are you paying for? (IE: "speeds up to")

Are you renting the Spectrum (Hitron) modem? You can purchase an Arris SB8200 these days for less than $100.
Last edited:
Spectrum doesn't charge extra for the modem. I think they used to. It's their modem. I have seen some things about buying your own so you can get to the data in the modem like line levels, etc. but not sure if they allow that presently. I am completely locked out of theirs.

I don't have any IPv6 stuff on my local network so didn't see the need to set up any IPv6 but maybe I should?
What speed tier are you paying for? Are you only using Spectrum Internet or do you have a combo package with TV and Telephone?

Here a couple of years back had XFinity run a new line to the box in the back yard. Buried it a week later then cut it while burying it and they had to do it all over again. This was due to them checking the wire before it went in to the house and before it went to the modem.

In the old house and this house XFinity replaced the old RG6 cable with RG11 cable.


I am guessing that Spectrum put a new wire in when you got Internet eh or checked what cabling you had?
We didn't have any Spectrum hookup at the house until about 6 months ago. It wasn't available at the street and a year ago wanted $5000 to install so we said no. Apparently they didn't have a cable at the street but did have one nearby. Then about 6 months ago they came by and said they could hook us up for the standard $100 install fee. So we changed from Starlink to Spectrum. The tech showed me a display that showed a map with a green dot for our house when he was done and I noticed other dots for other customers going north but not south. So we are the last house on the run (don't know that it matters - just interesting). The run from the street is some large coax for the first about 300 feet. Then they have a box in the yard and convert to RG11 for run to the house. Then converts to RG6 to the modem. We have internet and TV. TV is streaming so everything is network with no actual TV signals on the cable. We use a Roku box with an app for TV. Our speed is supposed to be "up to 300 Mbps". shows about 90 Mbps. That's plenty for what we do. We survived on 6 Mbps for years. But it seems even at the higher speeds we still get slow response and buffering sometimes.
Check to make sure the PFSense WAN interface status is at a Gb.


Status ==> Interfaces ==>

WAN shows ==> Media1000baseT <full-duplex> In/out packets
LAN shows ==> Media1000baseT <full-duplex> In/out packets

You should be getting speeds up to 300Mbps. As mentioned before connect a laptop with Linux to the modem Ethernet port and test speeds that way. The laptop should connect to the Modem Ethernet port at Gb speeds also.

Here first generation Surfboard modems with Gb had issues connecting to Gb Wan. A firmware update to the surfboard modem fixed that.
WAN shows 1000BaseT:
Media1000baseT <full-duplex>
But LAN shows 100BaseT
I have some old network equipment mixed in. Will check things out.
The connected switch is Gigabit. Maybe the cable. The house is wired with Cat5 cable so not getting 1Gb on it but would be nice to have the line to the switch be 1Gb.
Only writing about pfsense interfaces and a direct connect to modem.

You should be getting 300Mbs there.

On a tech visit isp can check speeds with their equipment at demarc to your house

Infrastructure cat5 will work at gb but not as good as 5e.

LAN Infrastructure can be a totally different issue.
Connected a laptop directly to the pfsense LAN port and it connected at 1 Gbit. The switch normally connected is Tp-link TL-SG108 which is supposed to be Gbit but doesn't connect at that speed with the same cable I used to connect the laptop. I wondered if other connections to the switch might slow down all ports but it appears it shouldn't.
So when connecting directly to Pfsense or modem so you get 300Mbs? Did you ever get that with spectrum?
So when connecting directly to Pfsense or modem do you get 300Mbs or over download speeds via Windows or Linux?

Did you ever get those speeds when Spectrum Internet was first installed?

Spectrum will never do diagnostics on your LAN except for the modem LAN port.

I like using those new thin cat6 cables now. Using these now in the "server" room and telco wall (with media panels). (also bedrooms, bathrooms, office, kitchen, living room et al).
Last edited:
I understand Spectrum is only responsible to my connection on their modem. But I am still interested in improving speed of the LAN although it looks fast enough to not be an issue. Connecting directly to the modem I get 300+ speed so that's great. Connecting to the LAN side of the pfsense box I sometimes show a 1Gb connection speed (indicated by the lights on the network connector). Often if would connect at slower speed and it always took a very long time for the connection lights to come on. I switched cables. Both were only about 2' long and Cat5e and marked as gigibit certified - same results with both. I can do a speed test when others aren't using the network. Desktop pc is connected to a gigabit switch with a short cable but shows connection as 100 Mbps.
Just looked up specs to your box...forgot what they were...
Did install and test PFSense connected to a Gb switch. It worked but never left it on for very long and just shipped it to you.

First update PFSense to most current version then copy and paste version of PFSense and BSD here.

Advantech AIMC-2000

NIC cards are Realtek 8119I

There used to be issues with PFSense using Realtek NICs which supposed to have been fixed.

Do this first:

Go to System / Advanced / Networking and tic "Disable hardware checksum offload"

if that doesn't work then in command line do this:

will copy and paste loading current Realtek drivers to BSD. What version of PFSense are you running. Have you updated.
In the dashboard it will tell you version of PFSense and BSD version.

This was for PFSense version that was running late 2022. Its not there anymore. I am pretty sure that the newest Realtek drivers are in the latest version of PFSense. Better to update.

fetch -v

pkg install -f -y realtek-re-kmod-197.00.pkg
Last edited:
Just updated to 23.05.1 and now says it is latest version.
Checked the box for disable checksum offload and rebooted
The laptop now connects to the LAN port at 1Gb consistently. It takes about 10-15 sec the first time but seems to be much quicker after the first connect. The Tplink switch still connects at 100Mbps. I plugged the switch into the WAN port just to test and it connected at 1 Gbps quickly. So it seems to be some combination of the port and what is being connected. Don't have time to do the driver update right now so will look at it later. I suppose I could switch configuration of which hardware port is WAN and LAN and see if the issue follows the LAN port or the hardware.
Good news Jim. Your TP-Link switch might be an issue. The Interface status is dynamic and should indicate speed of connection.