• You've been granted Beta access to this site, allowing you to explore some of the new features while they're still under construction. More information can be found in the Beta forum.

No landline, want Omni LTe send email messages

JonK

Member
Attaching SnapLink4,jpg with port 587 settings. Will try this when temp is up tomorrow and see.
 
Another question: SnapLink3 screenshot taken this evening shows alarm reset this morning at 11:57, yet console at same moment says Zone Not Ready. How can that be?
 

Attachments

  • SnapLink3.JPG
    SnapLink3.JPG
    45.4 KB · Views: 6
  • SnapLink4.JPG
    SnapLink4.JPG
    50.4 KB · Views: 5

pete_c

Guru
Here have not run Snaplink in a long time.  
 
Installed it on a Windows 2016 server.
 
Initially configured email with 587 and I saw a STARTLS error message.  Port 465 did not work at all.
 
So Snaplink for Windows will not work with modern email.
 
Then tested it to work with same local computer with STunnel installed.  That did work.
 
So to get email working with Snaplink install STunnel and configure it with SMTP port 25.
 
Then configure Snaplink to loopback address: 127.0.0.1 and port:25
 
Email test showed it working in my microsoft mail:
 
Snap-Link: PC ARM In House NIGHT
 

JonK

Member
Hi Pete,
 
Sorry for delay in reply. Have been trying to login to CocoonTech from Firefox for several weeks and get error 522 saying Cloudflare says the CocoonTech server is having a problem and to contact the admin. Finally tried my iPhone and it worked, so now using Chrome. Still no reason for Firefox not working.
 
But to the Snap-Link issue...I did install sTunnel and tried to set it up with Snap-Link, but must not understand it correctly, because it does not send the email alert message. Attached is how it is set up...can you please suggest what is wrong...I'll appreciate your help very much.
 
 

pete_c

Guru
Have been trying to login to CocoonTech from Firefox for several weeks and get error 522 saying Cloudflare says the CocoonTech server is having a problem and to contact the admin. Finally tried my iPhone and it worked, so now using Chrome. Still no reason for Firefox not working.
 
I have not been able to use Firefox on the Cocoontech  forum for years now.  I don't really like Chrome but use it for this forum.
 
Attached is how it is set up...can you please suggest what is wrong..
 
The "to:" address is incorrect.  
 
The to: address can be anything you want. 
 
Here use either a Microsoft outlook email or Google email address.  You can also configure it to text you rather than email you.
 
The SMTP gateway is your loopback address if you have STunnel running locally.  IE: 127.0.0.1 ** NO PORT HERE
 
The SMTP port could be anything you have STunnel configured for.  Make it 25 and configure STunnel to use port 25.
 
I am only using STunnel on old 32 bit Windows Server for SMTP mail today.
 
Configuration file shows:  (C:\Program Files\stunnel\config)
 
[gmail-smtp]
client = yes
accept = 25
connect = smtp.gmail.com:465
verifyChain = yes
CAfile = ca-certs.pem
checkHost = smtp.gmail.com
OCSPaia = yes 
 
IE: only used to send email out and not for receiving any email.
 
You need to generate certs for STunnel.
 
Read this:
 
https://www.stunnel.org/howto.html
 
This configuration on Windows has been used now for over 10 years.
 
I also am running STunnel on a Ubuntu server for my automation servers.  I do not really need to these days.

Thinking maybe today when installing STunnel in windows it will generate a cert for you automagically.
 

pete_c

Guru
BTW remove the image above with your email address as you do not want to get spammed.
 
Here is what your email configuration should look like if running STunnel on same computer in Windows.
 
You want to point your email configuration to the STunnel proxy which can be the same IP as the Windows computer or the Loopback address of the same computer.  
 
[sharedmedia=gallery:images:1483]

Configuration file shows: (C:\Program Files\stunnel\config) *NOTE: only configure STunnel for SMTP and nothing else.

[gmail-smtp]
client = yes
accept = 25
connect = smtp.gmail.com:465
verifyChain = yes
CAfile = ca-certs.pem
checkHost = smtp.gmail.com
OCSPaia = yes
 
You will see a little icon on the bottom right of your Windows screen showing that STunnel is running (it is a service).

[sharedmedia=gallery:images:1484]
 

JonK

Member
OK, set up Snap-Link the way you said, and I think the config file is fine, but authentication instructions you referenced say "just do a "make cert" ". Running from command line, error says not a recognized command. Showing my lack of experience again...how does a person run "make cert"?
 

JonK

Member
Also, sTunnel service is running (actually "sTunnel TLS Wrapper" service), but no icon in taskbar as you referenced.
 

JonK

Member
OK, loaded your config file but still not working. Your config file shows SMTP port 465, but when I set my SMTP port to 465, get no sending. Normally set at 587. Am attaching the way everything is set up...both Snap-Link and sTunnel are running continuously, although no sTunnel icon appears in the systray. B/c of size, have to send sTunnel config image separately.
 

Attachments

  • Alert Config.JPG
    Alert Config.JPG
    35.9 KB · Views: 2
  • SMTP Config.JPG
    SMTP Config.JPG
    31.8 KB · Views: 2
  • Snap-Link Config.JPG
    Snap-Link Config.JPG
    67.6 KB · Views: 2

pete_c

Guru
Yes that is the way the STunnel proxy works by using a cert and port 465 to get to the Gmail SMTP server.  
 
Locally on Snaplink you use port 25 to get to the STunnel proxy to send mail out.  
 
Typically port 465 is used for SSL and port 587 is used for TLS.  GMail uses port 465 for TLS.  
 
IE:   Snaplink email uses port 25 to the STunnel Proxy (127.0.0.1) and the STunnel proxy connects to Gmail to send out your Snaplink email.  
 
Will post version of STunnel that I am using for installation.  
 
STunnel V5.36 (2016)  

You will need to replace installed config directory with the one that I posted above after installation.
 
You can look at the logs under STunnel to see what is happening using Windows Explorer.
 
Thinking too you have to change your security settings in Google to use 3rd party apps.  
 

pete_c

Guru
Edit the configuration file:
 
; Debugging stuff (may be useful for troubleshooting)
;debug = info
;output = stunnel.log
 
So it reads like this:
 

; Debugging stuff (may be useful for troubleshooting)
debug = info
output = stunnel.log
 
And restart the STunnel service via control panel / services and test sending an email from Snaplink then look at the logs.

Setting up old included Outlook mail which is part of XP you can do the same configuring Outlook for SMTP port of 25 and local address of 127.0.0.1.
 

pete_c

Guru
Enabled logging here and had a look at it sending a test email.  STunnel logs are created in the config directory.
 

Code:
2021.08.25 10:41:10 LOG6[main]: Service [gmail-smtp] (FD=292) bound to 0.0.0.0:25
2021.08.25 10:41:10 LOG6[main]: Service [ssmtp] (FD=348) bound to 0.0.0.0:465
2021.08.25 10:41:46 LOG5[21]: Service [gmail-smtp] accepted connection from 127.0.0.1:1416
2021.08.25 10:41:46 LOG6[21]: s_connect: connecting 209.85.200.108:465
2021.08.25 10:41:46 LOG5[21]: s_connect: connected 209.85.200.108:465
2021.08.25 10:41:46 LOG5[21]: Service [gmail-smtp] connected remote server from 192.168.244.167:1420
2021.08.25 10:41:46 LOG6[21]: SNI: sending servername: smtp.gmail.com
2021.08.25 10:41:46 LOG6[21]: Peer certificate required
2021.08.25 10:41:46 LOG6[21]: Certificate accepted at depth=3: C=BE, O=GlobalSign nv-sa, OU=Root CA, CN=GlobalSign Root CA
 

pete_c

Guru
OK so tested this today and wanted to document it here.
 
Base testing OS and Hardware:  XPe on Atom tabletop touchscreens with 512Mb of RAM and custom X86 BIOS (Seabios)
 
XPe (via a custom coreboot Seabios (X86) running on my tabletop touchscreens which run OmniTouch Pro, Snaplink, Homeseer Touch, Microsoft SAPI speech and Ubuntu 20.04 via stock EFI bios.  (Squeezebox player, Kodi, et al).
 
1 - Install STunnel V5.49 - it will create certs and a service automagically. You can utilize these certs if you want.
2 - use the SMTP configure section mentioned above
3 - when running STunnel as a service or on its own you will see an icon on the bottom right of your deskop
4 - install Snaplink and update it and configure it to using local loopback address of 127.0.0.1 and port 25 
5 - configure an Email alert for alarm modes
6 - test it by enabling night mode or alarm and disabling it.  You will get an email or text depending on how you have it configured.
 
This is the email title I get when arming the panel.
 
Snap-Link: PC ARM In House NIGHT
 
[sharedmedia=gallery:images:1485]
 
 
Top