• You've been granted Beta access to this site, allowing you to explore some of the new features while they're still under construction. More information can be found in the Beta forum.

OmniPro II - Sudden failure

LQtechvn

Active Member
ano said:
Unless they have changed it, the board can't be started on 12v DC from the battery without it receiving AC.  The procedure is to power it with AC, then connect the battery. After that it will remain running with battery only, but it can't be started from battery only.  
 
Yep, Controller only start with AC. Controller only switch to battery after AC losses. 
 

madas

Member
anyone have any knowledge on the repair process and why i might have gotten my exact board back with the exact same problem?
 
power light comes on but no status light
 

ano

Senior Member
Madas said:
anyone have any knowledge on the repair process and why i might have gotten my exact board back with the exact same problem?
 
power light comes on but no status light
My guess would be they are no longer doing repairs, but did they charge you?
 

lanbrown

Active Member
The chip shortage might be playing a factor and this would then necessitate the need to repair rather than replace in some cases.  it is a possibility that they put the board through their "tests" and somehow it passed.  Or they found "an" issue and fixed that but didn't fix "the" issue.
 

pete_c

Guru
If the board was repaired then the serial number on the board would be the same serial number as the board you sent out to repair. 
 
When I burned up a new board HAI repaired the new board and sent it back to me sans any charges.
 
When you sent it in for repair did you tell / write to them about the LED indicator not functioning?

BTW I am guessing you checked the AC power supply. Personally here went to using the Elk equivalent because it had a ground terminal on it.
 

madas

Member
I did - I tried a different power supply.
 
I did report the exactly problem to them on the RMA form
 

bighorn

Member
@madas I have the exact same "NO CONTROLLER DATA" issue.  How does Leviton handle returns/repairs and RMA process?  Thanks!
 

bighorn

Member
I sent my OP2 to Leviton under their RMA program. Board came back and was reinstalled, project files uploaded with PCA and everything is working perfectly. I hope others have a similar experience if they need to have their OP board repaired.
 
Top