• You've been granted Beta access to this site, allowing you to explore some of the new features while they're still under construction. More information can be found in the Beta forum.

Powerlinc Serial and Powerhome

Mike

Senior Member
I've been trying to get my new serial Powerlinc connected to Powerhome. It does not seem to see the device. Has anyone else seen this issue?

I tried it on a second computer in case that was it, but that did not seem to help.

I'll go search around further, but if there is something special that needs to be done, please let me know.

EDIT: helps if I read the manual. I have it connected, working on response issues now.
 

dhoward

Member
Mike,

Be sure and check the phinsteon.rtf file. If you're still having problems, just let me know and we'll get it worked out.

Dave.
 

Mike

Senior Member
I found that, thank you it was quite detailed. After spending the last hour or so playing with this I think my 2414s is too old (version 1.1). I have not found a mapping of firmware to version, but from what I can tell I need to swap it out.

Frustrating if this assumption is correct as it literally just came yesterday from Smarthome. I bought one from AO probably 4 months ago and they were shipping the latest versions (for Elk integration). Back then I actually called and they verified it. I would have assumed I did not have to do this with smarthome (especially after so much time as well).

I guess this weekend may not be the one for this to work.

I did the whole port=? and it seems to crash the sdm. I am running the one referenced on your site. It comes back with PCL:disconnect=OK and then PLC:port=true and then uifinished:port=? but it crashes.
 

dhoward

Member
Mike,

Version 1.1 must be ancient! I just dug out my oldest PLC I had and it's revision 1.4 which is also out of date (firmware 2.9) but I never sent in for a replacement. In order for PowerHome to work properly with the current SDM versions, you would need revision 1.6 and firmware 2.10 or greater.

Im amazed that 1.1 is still shipping. Do you happen to know the firmware version? Ive heard that older versions of the PLC are somewhat desired for test purposes since they show traffic (albeit masked) of devices that are not in it's database.

Dave.
 

Mike

Senior Member
I couldn't tell. If there is a way I can check I'll look into it though. I couldn't find any reference on the net to 1.1.

Does this mean anything from the SDM:

SDM:DM=active, 1.01.79.226,8/6/2006 8:49:40 PM, responded,xx.xx.xx,2.12

where xx.xx.xx is the id I would have guess 2.12 is the firmware but that doesnt make sense.

Hmm. Now I need to play with this some more. I am getting more than I got last night and it seems that powerhome sees it now (completely different from last night and I rebooted multiple times).

Perhaps they reflashed this one and the sticker was not updated. I don't understand why I had problems last night though.
 

Mike

Senior Member
Now this is strange, the 15th device to be added using auto discovery was a relay switchlinc for an outside light. Well powerhome did not get anything after that switch as it seems the switch locked up. I actually cannot turn it off. I cycled the breaker and am looking up factory reset instructions now.

Powerhome on the other hand is working out all the links for the devices it found, which is kind of cool.
 

Digger

Senior Member
I finally got the SDM to see my USB powerlinc but the autodiscover doesnt want to work. More headbanging needed I guess.
 

Mike

Senior Member
You downloaded the core app and then turned it on and went to each one and linked it and then tapped it?

I yanked the relay out in my case, fortunately I have quite the supply of v1 switchlincs. I just put that one in a few weeks ago. The insteon gods were angry I bragged about a working installation I suppose.
 

Digger

Senior Member
I downloaded the app and turned on autolink and it didtn work. Tried a few times. Not sure why yet.

Try again tomorrow
 

Mike

Senior Member
Just to be clear, after turning on discovery mode, you started going to each switch and put it in link mode and then tapped it again to drop out of link mode?

I originally thought it would search the network for devices, which is not the way it works.
 

Digger

Senior Member
I had hoped that it automatically searched to me since that is what I would call auto discovery mode. To me its the same as linking to devices together pretty much.

I had a problem that I could not link switches to anything else. They just would not do it. I used the new power home tool to manually enter them into the ELK and they worked with the ELK fine. I have 2 switches that I dont know the address and it will be a pain to remove the cover (4 gang boxes) so I hoped this would work.

I will play with it more tonight but I am concerened that none of the ones I tried will link. I might need to move the USB Powerlinc somewhere else since it might not like where it is.

Now that I am thinking about this my house has a lot of GFCI circuits. I wonder if that is my problem. Maybe Insteon doesn't like GFCI's? They should state that in their literature if that was the case. I would have to another system. I hope I didnt waste over $1000.
 

Mike

Senior Member
It uses the link to find the addresses, and then searches out the links between what is there. You can then use the software to do the linking for you (so it seems to be a one time effort).

You don't actually link the switches, just put them into linking mode (I guess the controller can see it then). Then you assign descriptions and let it run for awhile (while it learns all the links).

I did not finish as I had to yank a relay switch so did not have all my switches entered. I'll have to see about doing that tonight.

I'll have to check and see what I have, I know I have at least 4 GFCI protected circuits.

Were there some specific conditions you found did not work? If it would help I could see about trying them with my setup (not sure how much this would prove though).
 

WayneW

Senior Member
PowerHome does autodiscovery of the links, but not the devices. the devices must momentarily be put into linking mode so that they broadcast their ID. PowerHome then picks up this ID and adds it to the database. My Insteon & Icon devices work fine behind a GFCI.
 

dhoward

Member
Unfortunately, Auto Discovery is not capable of scanning the network and discovering your Insteon devices without user intervention. This is by design in the Insteon protocol and a limitation of Insteon and not PowerHome. The thinking behind this decision was to keep your neighbors from discovering your device ID's and controlling your lights. It doesnt make sense really since you could leave PowerHome in Auto Discovery mode and you'll be able to register devices anytime your neighbors go to perform any manual linking.

Anyways, the only way for the PLC to "see" an Insteon device address is to place the PLC in discovery mode and then send an "Enter Linking Mode" command from a remote switch.

You should be able to use the Auto Discovery mode to determine the address of the switches without having to remove the wall plate covers. That's more or less its purpose since I didnt write down my addresses when installing and didnt feel like popping the covers off of all my switches.

Once PowerHome is aware of the devices within your network (through auto discovery or manual entry), it will discover all existing links between devices with no further user interaction. You can then edit, delete, or create new links just through the software.

Mike, if you've got firmware version 2.12, then you should be good to go. Sounds as if they didnt change the sticker.

Digger, if you're still having problems, let me know. The auto discovery is useful also for determining communication issues. If PowerHome doesnt hear the switch during auto discovery, then communications are probably borderline and link discovery will probably have problems as well. Repositioning the PLC may help. Ive had some users report that they have to plug the PLC into a different outlet than their computer is plugged into and that clears up any communication issues.

Dave.
 

Digger

Senior Member
I dont think the PLC is seeing any of the devices but I have to experiment more. It is in the same circuit but a different outlet from the PC. I have the PC going into a UPS so technically the PLC is on the same circuit as a GFCI and a UPS. Maybe that is supressing the comminication. I will have to experiement. I have a dedicated circuit to my home office but maybe I should have run two.

I understand the limitations you have because of Insteon and not your program. I havent had time to really experiment with it but once I do I am sure I will appreciate all it has to offer.

I need to wrp up my lighting issues so I can move onto HTPC :D

More Toys More Toys More Toys :D
 
Top