Zigbee 3.0 and HAI


Active Member
Has anyone tried using Zigbee 3.0 devices with the HAI Zim?
I've been reading that they should be backwards compatible and support the HA profile.
I want to try a few devices but hate buying them if they won't work.
I'm looking at things like the Smartthings remote button, water sensor, multipurpose sensor, etc.

I happened to get an old Control4 C4-therm zigbee tstat (made by Aprilaire) in a bunch of stuff. I tried to get it working with the HAI but gave up.
I did get it to join the Zim but that was it. Never got any temps. I tried learning directly into the HAI using PC Access.
It would say joined at the tstat but would give me "unknown device" with PC Access. Manually entering the device address didn't help.

Has anyone tried using Zigbee 3.0 devices with the HAI Zim?

Purchased a Centralite 3156105 Zigbee thermostat. Not sure what version of Zigbee it is. Only purchased it to test for a user here on the forum that was looking to replace his Omnistats.

It was all about the PCA configuration for the Zigbee thermostat and using the same ID I saw on the Zigbee ZIM. Once I put the ID in it worked fine with the basic functions. On the Homeseer touchscreens adding more temperature sensors and weather to the thermostat display here.

I am still using the old Omnistat2 serially wired here. Response times is fastest with these which I like. Never really touch the thermostat.
Both the HAI ZIM and HAI VRCOP are old these days and limited in function.

That said I did test out the Zigbee ZIM with a Centralite 3156105 Zigbee thermostat. It's still on line and working fine here. Not sure what generation of Zigbee the thermostat is. I can control it fine and it is still using same batteries from over a month ago. It is just sitting in the basement on the computer server rack. These were used for XFinity and the one I purchased has a Xfinity logo on it.

Most of the newer wireless are not zigbee or zwave but rather just wireless these days going to the cloud.

Here is an Omnibridge view of the Zigbee thermostat and an OmniProTouch view of same thermostat. (TMI).

Here running Homeseer Touch and HAI OmniProTouch on 15 tabletop 8" touchscreen computers. Due to WAF have only two in wall touchscreens these days. The zigbee polling makes it really slow to respond compared to the serially connected thermostat. Omnitouchpro thermostat.jpg

Last edited:
The Centralite 3156105 are dirt cheap on Ebay new or used. A tad more on Amazon.

The Centralite Perl should work too with the Zigbee ZIM. This is was many / or of the ISPs were using for their home automation stuff.

Ecobee might work too. Buy one from Amazon and test it...then return it to Amazon if it doesn't work. You can have it for 30 days to test.

I went to using the Ring Alarm / doorbell stuff for house two and just installed a ZWave thermostat and it works great.

I am using a Ring to MQTT (cloud connection) plugin which works with Home Assistant and Home Seer MQTT. I do not use the Android app to manage it unless I want to make a change. House number two is all WiFi Tasmota switches, Tasmota everything, Alexa and Ring (ZWave stuff).

Recently installed 4 PT Amcrest cameras inside of the house. Mounted them high up and POE.
You should be OK with Zigbee 3.0 devices. HAI follows the Zigbee 1.2 Home Automation profile (partially) which is backward compatible with Zigbee 3.0. Now HAI, didn't fully implement the Zigbee HA 1.2 spec, nut its enough for most things. It does locks, thermostats, light switches and dimmers and contact switches, but contacts can not be alarm zone triggers.
The Centralite 3156105 are dirt cheap on Ebay new or used. A tad more on Amazon.
Got a new Xfinity version dirt cheap on ebay. Hooked it up today and seems good. Changing settings on the tstat show up in a few seconds on PC Access. Changes from PC Access show up in a few seconds on the tstat. The only thing that doesn't seem to get communicated is the hold button. Don't know if the tstat doesn't communicate its state or HAI doesn't have it enabled in the ZIM. But all in all a good deal and a way to get a working temp sensor for a room.
Pretty miserable little manual. It tells you, if you want to find out how to enroll it on a Zigbee network find the manual on line. I thought that was a bit lame.
My is still running here on same batteries along with original Omnistat 2 serially connect. Let me try the old button....be back in a minute..will take a picture of the Omnitouch pro software ....

Hold doesn't work from thermostat to Omnitouch and Omnitouch to thermostat.

Works fine with Omnistat2 both ways.

Maybe it needs a firmware update?


Last edited:
Looks like its not implemented on HAI Zigbee. No big deal. It works fine as a tstat or a standalone temp sensor.
Tried to change hold on and hold off on the Zigbee zim and it is the same...changes are not seen on the thermostat...only on Omnitouch..took it apart and see traces for what may be a humidity sensor on it...
I'm not sure "hold" was in the early Zigbee spec the thermostat is based on, but HAI could add vendor specific commands, and it appears that is what they did. Snaplink CAN turn hold on and off remotely, but non-HAI Zigbee devices don't see the hold command. From what I see, HAI only implemented the very minimum commands for each device, and a few others are vendor-specific.
Thank you @ano

Yes Snaplink and Omniprotouch and PCA and Omnilink and Omni works fine with the Omnistat2 but not with a 3rd party Zigbee thermostat even though I see the option for hold there.