• You've been granted Beta access to this site, allowing you to explore some of the new features while they're still under construction. More information can be found in the Beta forum.

Gosund WiFi dimmer replacing firmware

Gouzoul

New Member
Hi all.
(sorry for my english, it's not my mother language)
 
I buyed multiple switch of GOSUND :
- 6 Gosund Dimmer DS1 (ref SW2-WIFI-V4.0)
- 2 Gosund 3 way  SW6 (not yet opened)
- 4 Gosund switch DS1 (ref SW5-WIFI-V1.0)
 
I want to flash the switches with Tasmota (to used with Domoticz after).
I am computer scientist, not electrician but i use raspberry, play with arduino, and volunter to learn.
 
 
I need some help to  flash the SW2-WIFI-V4.0 with raspberry pi, arduino or key CH340G ... but all of my test fail....
 
 
I do 2 tests : I have soldered wire on the board with 2 switches :
- Black : ground
- Red : 3.3V
- Yellow : TX
- Orange : RX
+ Green on GP00 (second test)
 
First test : tuya-convert
 
Multiple test, impossible to flash, the switch reboots every time.
Ok, i read the documentation, my firmware is to new, it needs a key from China to flash to ESP ...
 
Second Test : Raspberry Pi
On raspberry, i fallow this tuto : https://tasmota.github.io/docs/Flash-Sonoff-using-Raspberry-Pi/   respecting the wire schema
No result, impossible to send data or erase the ESP. 

ESP01: Failed to connect to Espressif device: Timed out waiting for packet header
 
I switch TX and RX, same result.
Connexion to GP00 to the ground, same error.
Click on button to have green flashing light, same error ...
 
Thirth test : Arduino
 
I connect the Arduino to ESB, using same wires.
Ground to ground, 3.3V to 3.3V, TX to RX, RX to TX, and GP00 to Ground
Using ESPTOOLS, same error ...
 
 
4th test : CH340G 
I buy on amazon a CH340G (recommanded by Tasmota)
I connect the 3.3V to 3.3V, ground to ground, grount to GP00 9using breadboard), TX to RX and RX to TX.
I use Tasmotizer to send data/erase or flash the ESP, same error, impossible to connect
 
 
At this moment, i don't understand what is my mistake...
I try with 2 differents switches and every test fail ...

Have you an idea for me ? I need help :p
I can post also photo of connexion if you want.
 
Thanks very much
 

pete_c

Guru
Welcome to the Cocoontech forum @Gouzoul.
 
I've read here on the forum that the newer switches do not work with Tuya-Convert.
 
Guessing your switch looks like this on the inside.
 
[sharedmedia=gallery:images:1470]
 
[sharedmedia=gallery:images:1471]
 
Carefully remove the top ribbon cable.

In order to be able to flash the device from the pins, make sure to disconnect the front panel from the rest of the device. If not done, the tuya MCU will prevent the ESP chip to be flashed.  
 
Then connect the 3.3VDC, Ground, RX and TX plus ground GPIO 0.  It should go to boot mode if you leave the gpio 0 to ground.
 
Use Tasmotizer to program your switch with the bin mentioned above.  It works fine for me in Windows 10 or Ubuntu Linux or RPi Linux.
 

 
Recently bricked one Gosund switch DS1 converting it from Espurna to Tasmota.  I ended up soldering wires to it and using Tasmotizer on it.

Use the Tasmota Gosund SW1 standard template for the switch.
 

ChuckieTodd

New Member
I gave this a shot.  Now I have the bottom LED lit in the dimmer strip.  The button seems to have no effect.
  
pete_c said:
Try this with no script...
 
Try to update with base Tasmota compressed == > tasmota basic bin gz file or tasmota minimal then
 
update with tasmota_v9.0.0.3_GS1.2.bin

I am still using this one though the switch was purchased in 2020.
 

pete_c

Guru
Must be the that the hardware is different these days.   For one standard relay WiFi Tasmota switch went over to the Martin Jerry brand on Amazon soldering to the pins to JTAG.
 

Gouzoul

New Member
Hello @pete_c and thank you for your help.
My main error is the connexion of ribbon cable ... 
Thanks to open my eyes :p
 
But i have again a problem ...

After multiple tests on multiple switch with difficulty, my Gosund Dimmer as flashed with Tasmota.
I configure Tasmota with my PC, it's work.
I give the template, it's work.
I try also with Domoticz + MQTT, It's work.
 
I removed the wires, reconnect all ribbon cable, re soldering the last wire (not on your picture).
I try with a 120V wire without lamp, i can use Tasmota and Domoticz...
 
Youhou all works ... I recieve message status from Tasmota and i can switch with Domoticz.
But the 6 lights do not work ... strange but not a real problem.
 
 
 
I unplug my current switch, connect the red to the red, the white to neutral, the black to supply.
Test ... nothing !
I continue to recieve message status from Tasmota and i can continue to switch the light with Domoticz but the lamp does not light ...
Strange ...
I unplug all, reconnecte an other not flashed Dimmer, it"s work ... my lamp is not burned...
 
To be sure, i reconnect ribbon cable, reinstall all ... same observation ...
 
No command to the relay ...
The question is "why ?
 
 
Do you have an idea ?
 
 
Thanks in advance for your help
 

pete_c

Guru
Once you have Tasmota firmware on it you can cut or shield the RX, TX, GND, GPIO 0 cables.  Connect the ribbon cable and put the switch back together again.  Any future firmware upgrades can be done via Tasmota.
 
Try the above mentioned single Tasmota bin file with no template to see how it works.
 
Personally I test the switch without installing it in a wall box.  Use a VOM to check voltages.
 
1 - cut the end off of a computer power cord and strip the ends.  IE: hot, neutral and ground.  Colors may be different.
2 - connect the switch hot, neutral and ground wires.
3 - using the VOM check the voltage on the load wires with one lead connected to the load and another connected to the neutral wire.
 
Be careful.  Turn on the switch and watch the voltage with the meter.  If it works then you can install the switch in a wall.  Recall too that the dimming of the switch is a touch sensor and you run your finger up and down the sensor to dim or brighten the switch.
 

pete_c

Guru
Here is the info I see on the installed running GoSund Dimmer switch:
 
Gosund Dimmer Module
Gosund_Dimmer1
Program Version 9.0.0.3(tasmota)
Build Date & Time 2020-11-05T01:14:14
Core/SDK Version 2_7_4_5/2.2.2-dev(38a443e)
Uptime 21T00:14:02
Flash write Count 717 at 0xF7000
Boot Count 8
Restart Reason Power On
Friendly Name 1 Tasmota_Dimmer1
 
AP2 SSId (RSSI) ICS-ESPurna (70%, -65 dBm)
Hostname OutdoorLights-7782
 
Note this switch is using the above tasmota bin file with no template enabled.
 

wrenchmonkey

New Member
Hi everybody, just joined the forum to ask this question, so sorry to be reviving a somewhat older thread. I had previously been using an older version of Tasmota on my Gosund dimmers with the script, and found it to be kinda buggy. Recently happened upon the v9.0.0.3_GS1.3 firmware and upgraded all of my switches.

The dimmer function seems to be much less buggy than the script, but I've encountered one issue I'm not sure how to resolve.

When the switch reboots for any reason, it resets the dimmer to 0. If the dimmer is set to zero, using the physical switch to power on just results in the top and bottom LED on the slider bar alternating blinking, and the light doesn't actually power on.

I can either send an MQTT command or use the web interface to set the dimmer to a value above zero, and then the light functions fine for a while until the switch reboots again, and then functionality is locked out again. As you can imagine, this really doesn't sit well with anybody else in the household (and it's pretty annoying for me too). Any ideas on what's causing it, or a good workaround?

I've been playing with node red having it monitor the stat/switch/RESULT mqtt topic and having it force the dimmer value above zero if it sees a zero value, but that's a messy way of dealing with it. I'd like to fix it if possible.

Anybody else seeing this issue and/or have a suggested fix? Thanks in advance!
 

pete_c

Guru
Welcome @wrenchmonkey to the Cocoontech forum.
 
 
Here only automate the Gosund dimmer switches with HA remotely.
 
I have manually used it and it has worked OK for me but I have never attention after a reboot.
 
Will check it out this week.
 
Noticed too that the newest revision sold of said switch does not work with current version of Tasmota with script or custom firmware posted here.
 
I have installed ESPHome but not yet tinkered much with it.
 
I did find this.  It is two years old now.
 

Gosund SW2 Implementation for ESP Home
 

jds

New Member
I have been using the alternative bin on a couple of gosund switches for over a year, and it worked great.  However, with the latest version of Home Assistant, the light topic no longer shows up. Other Tasmota switches still work fine, though. The status topic does show up in HA.  The light topic also shows up in MQTT explorer, so it seems likely an HA problem.  Has anyone else seen this?
 

pete_c

Guru
Here switched from the Gosund dimmers to the Martin Jerry dimmers with standard release Tasmota.

I am not too impressed with the dimmer design and the thick plastic used for the switch.

Maybe update the Gosund dimmers to latest release of Tasmota?

Here (slowly) have been updating my older Temperature sensors and still running fine Espurna devices to Tasmota devices.

The hardware designs are changing and becoming more proprietary for WiFi switch modifications with Tasmota.

Home Assistant has become more plug n play with the newest version today which I like.

 
 

jds

New Member
I am on the latest Tasmota that is compiled for this particular dimmer (9.0.0.3 v1.2).  I fixed my problem, which was lack of Tasmota integration. Turning setoption19 on then off again, fixed everything.  I should have figured that out quicker than I did. @Cocoonut, are you saying that you find the MJ better made than the Gosund?  I do like my Gosund dimmers, but see that the price of MJ is very reasonable on Amazon right now ($20).
 

pete_c

Guru
House #2 is a sandbox for WiFi automation.  Updating HA this morning VPNing over there...I am currently using the built in Tamota scheduling for the outdoor coach lamps and monitor with HA and Tasmota Admin...
 
Updating HA over there this morning via command line...
 
ha core update --version 2022.2.3
 
I have both the old Gosund dimmer and new MJ dimmers going...there...they are totally different looking and personally right now do not care....mostly about function... and the MJ is easier to program and update
 
[youtube]http://youtu.be/uU7oy-Kz7T8[/youtube]
 
While I built a new server to run HA there still using the Armbian Pine64...
 

pete_c

Guru
So while logged in to house #2 updated the Gosund dimmer to current Tamota and template to see how that works...also using Ring alarm hub in house #2 with events configured based on Ring sensors...
 
Works with template...will do a visual later on today...pita to work in two subnets via VPN...
Using Wyse dual power monitoring outside device for landscaping lighting...will update that one too...
 
[sharedmedia=gallery:images:1512]
 
Martin Jerry Dimmer - deck coach lamps
[sharedmedia=gallery:images:1514]
 
GoSund Dimmer - front door coach lamps
[sharedmedia=gallery:images:1513]

Now updating two HA servers in main house....geez just updated this past weekend....

One HA server is destined for house #2 and is running both Homeseer and Home Assistant.

@jds...
you got me looking here at my HA setups as I have not done much but install more switches...


 
 

pete_c

Guru
Status update of Gosund dimmer 
 
Update to current scripting version of Tasmota 10.X scripting bin and script  did not work with the Gosund dimmer.
 
IE:
 
1 - installed minimal bin gz file
2 - installed current tasmota-scripting.bin.gz
3 - copy and pasted script

Switch did not work via web gui or manually.
 
Downgraded back to tasmota_v9.0.0.3_GS1.1
 
1 - installed minimal bin gz file
2 - installed tasmota_v9.0.0.3_GS1.1
 
Most likely then will decommission this GoSund switch and replace it with a Martin Jerry dimmer. I have two MJ dimmers currently implemented and running file.

Will have to look for a deeper faceplate. Really liked the look of the Gosund dimmer switch over the MJ dimmer switch.
 
The Leviton deeper plates (not bigger) used to be at the big box stores and I cannot find them any more.
 
Top