Problem with Automation Studios software

So I am at my wits end here.  About 2 weeks ago I lost power at my house.  Since then I have unable to get both of my touchscreens to work for any length of time.  Let me give you some history.  I am running 2 touchscreens with Automation studio in the simulator mode.  The reason why I did this is because Omni Pro Touch wouldn't work right with the internet updates that I wanted to run.  Anyway I digress, it has been running this way for about 18 months now with no issue.  After my power outage I reset my modem, router and security panel because I could not get the automation studio software to connect.  I also tried restarting the touchscreens.  After this I started to do a little more troubleshooting and noticed that my 1st Controller ip address was changed to something else.  I changed it back and it initally reconnected with the panel but after about 20 minutes it lost its connection.  The other panel had the same problem but then it lost connection with the panel after about 2 days.  I have tried putting in a new IP Address, have looked at the router to make sure that it didnt default to something odd, have gone into the HAI panel and have both reset the two options of RAM and the option right before that but still can not get the touchscreeens to work.  In addition I have tried to connect with my laptop computer making sure that I have the controller address and all of the required information to be able to run the simulator but I can not connect this way either.  What am I missing?
I have also the Haiku app and can not connect either.  I tried clearing out my settings and enter anything again but still no luck
What firmware revision are you running on the panel?
Here I have settled now on 3.13 and using a microrouter between the NIC on the OPII and the rest of my network.
I have not had any issues to date with it in place.  Its been about 2 months (?).
Before I did this I did have some odd resets and networking issues with FW3.13
I did also have random issues with FW 3.12 until I did similiar as above.   The problems manifested differently though than the 3.13FW.
I have updated to 3.13 when it came out.  This problem only started when I lost power to the house.  So it has to be caused by that.
It is understood that your issues started with your power outage.
It could be an issue related to the power outage with your test computer, network switch or software.
Rule that out first.
Test the application with a direct connection to a test switch and your HAI panel.
Yup; there are issues with FW 3.13.  My personal issues related to networking/resting issues.  Other users / issues with FW 3.13 have been documented here.
Yes I was able to connect via a serial port because the network connection is oddly hit and miss.  Is my best option to go back to 3.11?