HAI PC Dealer Access on MBP M1 with Parallels


New Member
Hi all,
I've been trying to get the latest EOL version of Dealer PC Access installed on my Apple MBP laptop, and been having issues - can't get past the "This application requires the .NET framework version 2.0 to be installed." installer screen. The "Proceed" button doesn't do anything...

I'm starting to wonder if this is due to the ARM-virtualization with Parallels and win11, or maybe I'm missing something with the .NET stuff or VB...

Any help greatly appreciated! Anyone else able to get this to work on an M1 MBP? Worked great on my old intel-based MBP...
I just ran it on my Mac using Parallels. I have other software that uses old dependencies so I might've already installed it.

I found that all the dependencies I needed either had a WOA version or the x86 version worked. You might want to try to download .NET v.2 and installing and seeing if that works.
You can but a PC laptop for under $130 today. I bought a mini pc for about $60. Monitors have multiple inputs and Bluetooth mice and keyboards easily connect to 2 or 3 computers. Why put this stuff on your Mac which has to emulate Windows on Intel, and then has to emulate the M1 to Intel? Plus PC Access is iffy on Win. 11, but below, it works pretty good.