Home Assistant Alarm Keypad display

madas

Member
I had to create an ini and mount that back to the file system just to add this setting. Previously I also was using the docker-compose yaml file.

I'm using the Fire tabs right now as they are so cheap on sale.
 

pete_c

Guru
I see the update in the update.json file so changed it ...

"mqtt_discovery_area_code_required": "",

to this

"mqtt_discovery_area_code_required": "1",

I am updating 3 boxes here...2 are production and one is testing...all running Ubuntu Linux.

Number 4 testing box is running HA in a VB in Ubuntu...
 

pete_c

Guru
This is my set up in theoptions file:

"mqtt_discovery_name_prefix": "",
"mqtt_discovery_ignore_zones": "15",
"mqtt_discovery_ignore_units": "65-255",
"mqtt_discovery_area_code_required": "1",
"mqtt_discovery_override_zone": "",
"notify_area": false,
"notify_message": false,

Watching boot up...

[services.d] starting services
[services.d] done.
2022-10-21 10:58:04 [OmniLinkBridge.CoreServer INF] Started version 1.1.13.0 on Unix 5.4.0.131 with ["OmniLinkBridge.Modules.OmniLinkII", "OmniLinkBridge.Modules.LoggerModule", "OmniLinkBridge.Modules.TimeSyncModule", "OmniLinkBridge.Modules.MQTTModule"]

2022-10-21 10:58:12 [OmniLinkBridge.Modules.LoggerModule VRB] Initial AreaStatus 1 Alarm, Status: OFF, Alarms: 0

Ahh....see that the UI options do not save...so did the Yaml editing and that saved it....wierd cuz I used nano to edit the options.json file...

Now I see the keyboard....so editing the option.json file didn't do anything...need to edit using yaml editor and not UI editor...

Do see this error when starting plugin...

Add-on version: 1.1.13
You are running the latest version of this add-on.
parse error: Expected string key before ':' at line 1, column 4
[11:03:32] ERROR: Unknown HTTP error occured
System: (amd64 / generic-x86-64)
Home Assistant Core: 2022.10.5
Home Assistant Supervisor: 2022.10.0
-----------------------------------------------------------
Please, share the above information when looking for help
or support in, e.g., GitHub, forums or the Discord chat.
-----------------------------------------------------------
 
Last edited:

madas

Member
is your area definitely area 1?

can you look in your ini file and see what it looks like?

no errors in mine.

2022-10-21 07:04:26 [OmniLinkBridge.CoreServer INF] Started version 1.1.13.0 on Unix 3.10.105.0 with ["OmniLinkBridge.Modules.OmniLinkII", "OmniLinkBridge.Modules.LoggerModule", "OmniLinkBridge.Modules.TimeSyncModul
e", "OmniLinkBridge.Modules.MQTTModule"]
2022-10-21 07:04:26 [OmniLinkBridge.Modules.OmniLinkII DBG] Controller: Connect
2022-10-21 07:04:26 [OmniLinkBridge.Modules.OmniLinkII DBG] Controller Status: Connecting
2022-10-21 07:04:26 [OmniLinkBridge.Modules.MQTTModule DBG] Connected
2022-10-21 07:04:26 [OmniLinkBridge.Modules.OmniLinkII INF] Controller is OmniPro II firmware 4.0B

i suspect your ini file isn't formatted correctly.
 
Last edited:

pete_c

Guru
Its working now. I was also upgrading HA core here which I do via command line these days.

I do not have an INI file these days. It is called an options.json file. I edited this file and the changes would not take such that there is probably another options file some place.

I was able to change the options in the yaml editor in HA as the UI editor doesn't save my changes.

The plugin is located in the HACS configuration UI in HA.
 
Top