Home Assistant Alarm Keypad display

pete_c

Guru
Here using Home Assistant (and Homeseer) to manage a Ring Alarm (and doorbell and thermostat) for house #2 and OmniPro2 panel in house #1.

I see an console keypad for the Ring Alarm system but do not see one for the OmniLinkBridge app.

Ring card is defined as:

type: alarm-panel
states:
- arm_home
- arm_away
- arm_night
- arm_vacation
- arm_custom_bypass
entity: alarm_control_panel.ring_alarm
name: Ring Alarm

RingAlarm-1.jpg

OmniLinkBridge is defined as above.

type: alarm-panel
states:
- arm_home
- arm_away
- arm_night
- arm_vacation
- arm_custom_bypass
entity: alarm_control_panel.in_house
name: OmniPro Alarm

OmniLinkBridge.jpg

I have added new color themes for the above displays and they do look much nicer.

Anybody doing this configuration for keypad console for the OmniLinkBridge app?
 

pete_c

Guru
No.

I didn't know that there was a auto produced alarm keyboard until I installed the Ring alarm add on.
 

madas

Member
I'm new to HA but was surprised there was't a pin pad.

I looked at some third party options and it is either putting the card behind a pin (which is a terrible user experience) or using something like Alarmo with a bunch of automations to mirror the alarmo state over to the HAI.

Did you find any better options?

who exactly would we need to fix this? would it be a custom lovelace card?
 

pete_c

Guru
Did you find any better options?

No. I am OK with it though. I am still using Omnitouch Pro software on my tabletop tablets which works fine.

Wife prefers to use the analog console keypad here so have one configured on the main floor.

who exactly would we need to fix this?

Not sure but it might be related to how the MQTT variables are named in the plugin.

would it be a custom lovelace card?

Maybe. I built a remote control lovelace card for an old Panasonic Plasma TV.
 

madas

Member
I added Alarmo and created automations so when Alarmo is armed it arms the Omni, when Alarmo is disarmed it disarms the Omni. Not sure if anyone else has tried this and has any feedback. Not ideal but better than nothing.
 

madas

Member
I programmed the same ones into Alarmo.

its not a great solution but it works. I'm looking around at the lovelace cards now to see if maybe there is a way to utilize the generic alarm panel pin pad to just collect a PIN code and then send an MQTT message with that code. This would solve the problem in a much nicer way.
 

pete_c

Guru
I am guessing that it is the methodology or naming convention being used with the OmniLinkBridge plugin.

This is the Lovelace template for the Ring Alarm Keypad.

type: alarm-panel
states:
- arm_home
- arm_away
- arm_night
- arm_vacation
- arm_custom_bypass
entity: alarm_control_panel.mokena_alarm
name: Ring Alarm
theme: Caule Black Aqua

and the one for the OmniBridgeLink alarm keypad

type: alarm-panel
states:
- arm_home
- arm_away
- arm_night
- arm_vacation
- arm_custom_bypass
entity: alarm_control_panel.in_house
name: OmniPro Alarm
theme: Caule Black Aqua

Maybe it is just the verbiage alarm_control_panel.in_house

Way back did use two areas then changed it to one area but the "in_house" description remained. This morning changed it back to two areas, removed one area the changed in_house to alarm. Wrote it to the alarm panel using PCA. Looks like a bug in the firmware as in PCA I have the alarm defined for one area although when it reads the firmware it keeps seeing two areas.

Then went to the HA plugin and did a rebuild with new variable names to see if that changes anything. Hopefully it doesn't mess with my automations / scripts that I am using for Amazon Alexa TTS.

alarm_control_panel.in_house remained after my changes and still see no keypad.

Looking at the original ini file and new HA file I do not see where the keycode setting is present to disarm. I read somewhere if the keycode is present then a keypad will not show up unless you utilize the manual alarm configuration.

# HAI / Leviton Omni Controller
controller_address =
controller_port = 4369
controller_key1 = 00-00-00-00-00-00-00-00
controller_key2 = 00-00-00-00-00-00-00-00
# Used in notifications
controller_name = OmniLinkBridge
 
Last edited:

madas

Member
did you restart your MQTT server to flush out any of the cached data?

I don't have any codes defined in my OmniLinkBridge config either but it shouldn't need it as I can arm/disarm when using PCA and it doesn't need a user pin there either.

I'm curious about the comparison between Ring and this one. If the LoveLace cards are the same there must be something different in the entity itself that causes the code screen to show up?

Using the alarmo entity i see a similar lovelace config

type: alarm-panel
states:
- arm_home
- arm_away
entity: alarm_control_panel.whole_house_2

and if I flip-flip between the alarmo entity and the hai entity the pin pad disappears. I'm not sure how to dig into the entity itself but thats the next step.
 

pete_c

Guru
did you restart your MQTT server to flush out any of the cached data?

A few times yesterday as my "Alexa Media" plugin TTS function quit working and then worked by end of day yesterday.

Let me know how it goes with the MQTT alarm control panel stuff today.

Here today configuring the Broadlink plugin and Broadlink RM4 in house two.
 

madas

Member
it 100% works. i'm tweaking the extended config now to get the correct mappings - but this will do what we need.
 
Top