UPstart & config files in a virtual PC environment


Staff member
I have all my HA management software running in a virtual machine (so I don't have to reinstall it when I rebuild my main PC), but I store the config files on the host pc, since Virtual PC lets you map a folder on the host pc as a system drive on the virtual pc. This always worked great, but I noticed that with the latest build of UPstart (my previous version was way older, so can't say in what build this problem started), it isn't saving any of my changes to file anymore, eventho it says it has.

I copied the config file to the local desktop of the virtual PC, and it has no problems saving the file then, so I assume there is a bug in the code that can't handle saving to network drives (since that's how Virtual PC displays the mapped foldeR).

Since this worked before, I am wondering if anyone ran into a similar issue before, and if there is a fix for it, since it's quite annoying :)
Interesting. Next time I fire up Upstart I'll check my version. I save my UPB files to a remote mapped drive without issue...

I know this is a band-aid, but you can try creating a virtual drive on the VPC with the old DOS command "subst" that points to your mapped drive. It's a bit redundant because you end up with two drive letters on the VPC that point to the same location, however I have used it before with other old apps that for whatever reason would not recognize a mapped drive. They never seemed to have a problem with a subst-created drive.

An example:

If (on the VPC) you have drive "z:" mapped to \\server\share then:
SUBST y: z:\
will create a "local" "y:" drive that points to "z:".

Point your upstart config stuff to the z: drive and see if that works. If it does, you'll have to add the subst command to a batch script that runs on startup on the VPC to get it created after restarts.


Edit: Corrected typos...